Bug 161194 - [67cat] NullPointerException When closing Report Issue Window
[67cat] NullPointerException When closing Report Issue Window
Status: RESOLVED DUPLICATE of bug 161189
Product: connecteddeveloper
Classification: Unclassified
Component: Issuetracking Framework
6.x
PC Windows XP
: P2 (vote)
: TBD
Assigned To: issues@versioncontrol
issues@connecteddeveloper
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-25 21:44 UTC by eruvel
Modified: 2009-07-27 09:20 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description eruvel 2009-03-25 21:44:36 UTC
[ BUILD # : 200903250219 ]
[ JDK VERSION : 1.5.* ]

Click Team->Report and Issue and then close the window and it will
throw this stack trace:

java.lang.IllegalStateException: [Winsys] TopComponent
org.netbeans.modules.bugtracking.ui.issue.IssueTopComponent throws
exception/error from its componentClosed() method.
Please repair it! Probable cause is at
org.netbeans.modules.bugtracking.ui.issue.IssueTopComponent.componentC
losed(IssueTopComponent.java:318)

        at
org.openide.windows.WindowManager.logThrowable(WindowManager.java:361)

        at
org.openide.windows.WindowManager.componentCloseNotify(WindowManager.j
ava:315)
        at
org.netbeans.core.windows.WindowManagerImpl.notifyTopComponentClosed(W
indowManagerImpl.java:1014)
        at
org.netbeans.core.windows.Central.removeModeTopComponent(Central.java:
990)
        at
org.netbeans.core.windows.Central.userClosedTopComponent(Central.java:
1969)
        at
org.netbeans.core.windows.view.DefaultView.userClosedTopComponent(Defa
ultView.java:741)
        at
org.netbeans.core.windows.view.ui.TabbedHandler.actionPerformed(Tabbed
Handler.java:315)
        at
org.netbeans.swing.tabcontrol.TabbedContainer.postActionEvent(TabbedCo
ntainer.java:692)
        at
org.netbeans.swing.tabcontrol.TabbedContainerUI.shouldPerformAction(Ta
bbedContainerUI.java:162)
        at
org.netbeans.swing.tabcontrol.plaf.DefaultTabbedContainerUI.access$270
0(DefaultTabbedContainerUI.java:109)
        at
org.netbeans.swing.tabcontrol.plaf.DefaultTabbedContainerUI$DisplayerA
ctionListener.actionPerformed(DefaultTabbedContainerUI.java:1258)
        at
org.netbeans.swing.tabcontrol.TabDisplayer.postActionEvent(TabDisplaye
r.java:557)
        at
org.netbeans.swing.tabcontrol.TabDisplayerUI.shouldPerformAction(TabDi
splayerUI.java:185)
        at
org.netbeans.swing.tabcontrol.plaf.BasicTabDisplayerUI.access$1500(Bas
icTabDisplayerUI.java:117)
        at
org.netbeans.swing.tabcontrol.plaf.BasicTabDisplayerUI$BasicDisplayerM
ouseListener.performCommand(BasicTabDisplayerUI.java:723)
        at
org.netbeans.swing.tabcontrol.plaf.BasicTabDisplayerUI$BasicDisplayerM
ouseListener.potentialCommand(BasicTabDisplayerUI.java:708)
        at
org.netbeans.swing.tabcontrol.plaf.BasicTabDisplayerUI$BasicDisplayerM
ouseListener.mouseReleased(BasicTabDisplayerUI.java:756)
        at
java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:23
1)
        at
java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:23
1)
        at java.awt.Component.processMouseEvent(Component.java:5501)
        at
javax.swing.JComponent.processMouseEvent(JComponent.java:3135)
        at java.awt.Component.processEvent(Component.java:5266)
        at java.awt.Container.processEvent(Container.java:1966)
        at java.awt.Component.dispatchEventImpl(Component.java:3968)
        at java.awt.Container.dispatchEventImpl(Container.java:2024)
        at java.awt.Component.dispatchEvent(Component.java:3803)
        at
java.awt.LightweightDispatcher.retargetMouseEvent(LightweightDispatche
r.java:4212)
        at
java.awt.LightweightDispatcher.processMouseEvent(LightweightDispatcher
.java:3892)
        at
java.awt.LightweightDispatcher.dispatchEvent(LightweightDispatcher.jav
a:3822)
        at java.awt.Container.dispatchEventImpl(Container.java:2010)
        at java.awt.Window.dispatchEventImpl(Window.java:1778)
        at java.awt.Component.dispatchEvent(Component.java:3803)
        at java.awt.EventQueue.dispatchEvent(EventQueue.java:463)
        at
org.netbeans.core.TimableEventQueue.dispatchEvent(TimableEventQueue.ja
va:104)
        at
java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThr
ead.java:242)
        at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThrea
d.java:163)
        at
java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:157)
        at
java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:149)
        at
java.awt.EventDispatchThread.run(EventDispatchThread.java:110)

java.lang.NullPointerException

        at
org.netbeans.modules.bugtracking.ui.issue.IssueTopComponent.componentC
losed(IssueTopComponent.java:318)
        at
org.openide.windows.WindowManager.componentCloseNotify(WindowManager.j
ava:313)
        at
org.netbeans.core.windows.WindowManagerImpl.notifyTopComponentClosed(W
indowManagerImpl.java:1014)
        at
org.netbeans.core.windows.Central.removeModeTopComponent(Central.java:
990)
        at
org.netbeans.core.windows.Central.userClosedTopComponent(Central.java:
1969)
        at
org.netbeans.core.windows.view.DefaultView.userClosedTopComponent(Defa
ultView.java:741)
        at
org.netbeans.core.windows.view.ui.TabbedHandler.actionPerformed(Tabbed
Handler.java:315)
        at
org.netbeans.swing.tabcontrol.TabbedContainer.postActionEvent(TabbedCo
ntainer.java:692)
        at
org.netbeans.swing.tabcontrol.TabbedContainerUI.shouldPerformAction(Ta
bbedContainerUI.java:162)
        at
org.netbeans.swing.tabcontrol.plaf.DefaultTabbedContainerUI.access$270
0(DefaultTabbedContainerUI.java:109)
        at
org.netbeans.swing.tabcontrol.plaf.DefaultTabbedContainerUI$DisplayerA
ctionListener.actionPerformed(DefaultTabbedContainerUI.java:1258)
        at
org.netbeans.swing.tabcontrol.TabDisplayer.postActionEvent(TabDisplaye
r.java:557)
        at
org.netbeans.swing.tabcontrol.TabDisplayerUI.shouldPerformAction(TabDi
splayerUI.java:185)
        at
org.netbeans.swing.tabcontrol.plaf.BasicTabDisplayerUI.access$1500(Bas
icTabDisplayerUI.java:117)
        at
org.netbeans.swing.tabcontrol.plaf.BasicTabDisplayerUI$BasicDisplayerM
ouseListener.performCommand(BasicTabDisplayerUI.java:723)
        at
org.netbeans.swing.tabcontrol.plaf.BasicTabDisplayerUI$BasicDisplayerM
ouseListener.potentialCommand(BasicTabDisplayerUI.java:708)
        at
org.netbeans.swing.tabcontrol.plaf.BasicTabDisplayerUI$BasicDisplayerM
ouseListener.mouseReleased(BasicTabDisplayerUI.java:756)
        at
java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:23
1)
        at
java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:23
1)
        at java.awt.Component.processMouseEvent(Component.java:5501)
        at
javax.swing.JComponent.processMouseEvent(JComponent.java:3135)
        at java.awt.Component.processEvent(Component.java:5266)
        at java.awt.Container.processEvent(Container.java:1966)
        at java.awt.Component.dispatchEventImpl(Component.java:3968)
        at java.awt.Container.dispatchEventImpl(Container.java:2024)
        at java.awt.Component.dispatchEvent(Component.java:3803)
        at
java.awt.LightweightDispatcher.retargetMouseEvent(LightweightDispatche
r.java:4212)
        at
java.awt.LightweightDispatcher.processMouseEvent(LightweightDispatcher
.java:3892)
        at
java.awt.LightweightDispatcher.dispatchEvent(LightweightDispatcher.jav
a:3822)
        at java.awt.Container.dispatchEventImpl(Container.java:2010)
        at java.awt.Window.dispatchEventImpl(Window.java:1778)
        at java.awt.Component.dispatchEvent(Component.java:3803)
        at java.awt.EventQueue.dispatchEvent(EventQueue.java:463)
        at
org.netbeans.core.TimableEventQueue.dispatchEvent(TimableEventQueue.ja
va:104)
        at
java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThr
ead.java:242)
        at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThrea
d.java:163)
        at
java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:157)
        at
java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:149)
        at
java.awt.EventDispatchThread.run(EventDispatchThread.java:110)
Comment 1 Tomas Stupka 2009-03-26 12:03:05 UTC

*** This issue has been marked as a duplicate of 161189 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo