Bug 161144 - apisupport.project tests don't pass
apisupport.project tests don't pass
Status: RESOLVED DUPLICATE of bug 61014
Product: apisupport
Classification: Unclassified
Component: Project
6.x
Other All
: P2 (vote)
: TBD
Assigned To: rmichalsky
issues@apisupport
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-25 14:43 UTC by Jaroslav Tulach
Modified: 2009-03-25 15:00 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Simple fix to make the SuiteProjectTest pass (903 bytes, patch)
2009-03-25 14:50 UTC, Jaroslav Tulach
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jaroslav Tulach 2009-03-25 14:43:02 UTC
Is anyone actually running them somewhere? Please take a look at http://ruhudson4qe.russia if you seek for an easy way 
to run the tests daily.

    [junit] Testcase: 
testSuiteEvaluatorReturnsUpToDateValues(org.netbeans.modules.apisupport.project.suite.SuiteProjectTest):  Caused an 
ERROR
    [junit] null
    [junit] java.lang.NullPointerException
    [junit]     at 
org.netbeans.modules.apisupport.project.suite.SuiteProjectTest.testSuiteEvaluatorReturnsUpToDateValues(SuiteProjectTest.java:103)
    [junit]     at org.netbeans.junit.NbTestCase.access$200(NbTestCase.java:88)
    [junit]     at org.netbeans.junit.NbTestCase$2.doSomething(NbTestCase.java:336)
    [junit]     at org.netbeans.junit.NbTestCase$1Guard.run(NbTestCase.java:273)
    [junit]     at org.netbeans.junit.NbTestCase.runBare(NbTestCase.java:355)
    [junit]     at org.netbeans.junit.NbTestCase.run(NbTestCase.java:213)
Comment 1 Jesse Glick 2009-03-25 14:50:09 UTC
They ought to be fixed up and included in the core-main script.
Comment 2 Jaroslav Tulach 2009-03-25 14:50:59 UTC
Created attachment 78826 [details]
Simple fix to make the SuiteProjectTest pass
Comment 3 rmichalsky 2009-03-25 15:00:31 UTC
apisupport.project tests hasn't been taken care of for a long time and are not in state to be run regularly. I work on
them now and then, but it would still take substantial amount of time to fix them all, no point to file P2 issue on it. 

Otherwise thanks for the fix for SuiteProjectTest, I guess there will be more of them affected by recent changes in test
infrastructure, I fixed some others yesterday as part of issue #159622.

*** This issue has been marked as a duplicate of 61014 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo