Bug 160831 - [67cat] java.net.SocketException: Connection reset
[67cat] java.net.SocketException: Connection reset
Status: RESOLVED WORKSFORME
Product: db
Classification: Unclassified
Component: Code
6.x
All All
: P3 (vote)
: 7.2
Assigned To: Jiri Rechtacek
issues@db
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
:
: 161405 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-22 23:06 UTC by chronosmark
Modified: 2012-05-21 16:35 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.25 KB, text/plain)
2009-03-22 23:06 UTC, chronosmark
Details

Note You need to log in before you can comment on or make changes to this bug.
Description chronosmark 2009-03-22 23:06:28 UTC
Build: NetBeans IDE Dev (Build 200903121546)
VM: Java HotSpot(TM) Client VM, 11.2-b01, Java(TM) SE Runtime Environment, 1.6.0_12-b04
OS: Windows XP, 5.1, x86

User Comments:
chronosmark: When attempting to open the tables node on a connection that should be active.



Stacktrace: 
org.netbeans.modules.db.metadata.model.api.MetadataModelException: org.netbeans.modules.db.metadata.model.api.MetadataException: com.ibm.db2.jcc.a.pm: [jcc][t4][2030][11211][4.0.100] A communication error occurred during operations on the connection's underlying socket, socket input stream, 
or socket output stream.  Error location: Reply.fill().  Message: Connection reset. ERRORCODE=-4499, SQLSTATE=08001
        at org.netbeans.modules.db.metadata.model.JDBCConnMetadataModel.runReadAction(JDBCConnMetadataModel.java:99)
        at org.netbeans.modules.db.metadata.model.api.MetadataModel.runReadAction(MetadataModel.java:89)
        at org.netbeans.modules.db.explorer.node.TableNodeProvider.initialize(TableNodeProvider.java:99)
        at org.netbeans.api.db.explorer.node.NodeProvider.getNodes(NodeProvider.java:103)
        at org.netbeans.modules.db.explorer.node.NodeRegistry.getNodes(NodeRegistry.java:149)
        at org.netbeans.api.db.explorer.node.ChildNodeFactory.createKeys(ChildNodeFactory.java:104)
Comment 1 chronosmark 2009-03-22 23:06:38 UTC
Created attachment 78605 [details]
stacktrace
Comment 2 Jiri Rechtacek 2009-04-06 16:52:20 UTC
*** Issue 161405 has been marked as a duplicate of this issue. ***
Comment 3 Jiri Rechtacek 2009-04-06 16:54:56 UTC
It's caused by broken connection, nice to have try/catch statement which handles such socket problems.
Comment 4 Jaroslav Havlin 2012-05-21 16:35:52 UTC
Cannot reproduce. Probably related to bug 165623.
Please reopen if you encounter the problem again. Thanks.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo