Bug 160747 - [67cat] Continue button is disabled when on breakpoint
[67cat] Continue button is disabled when on breakpoint
Status: CLOSED DUPLICATE of bug 167776
Product: debugger
Classification: Unclassified
Component: Code
6.x
PC Windows Vista
: P3 with 2 votes (vote)
: 6.x
Assigned To: Martin Entlicher
issues@debugger
: RANDOM
: 163360 164800 164802 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-20 16:10 UTC by denbo
Modified: 2010-04-29 09:49 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description denbo 2009-03-20 16:10:44 UTC
[ BUILD # : 200902231810 ]
[ JDK VERSION : 1.6.* ]

When I'm in a running debuggin session, on a breakpoint, the
"continue" button is disabled and the menu item Debug>Continue is
disabled too. 
As a workaround, I can press "pause", then "continue" is available.
Comment 1 denbo 2009-03-20 18:27:32 UTC
Weird, I cannot reproduce the problem now. Will keep an eye on this..
Comment 2 Martin Entlicher 2009-04-09 09:46:11 UTC
This is a random issue, occasionally it happens to me too when continue is pressed quickly between fast breakpoint hits.
Comment 3 Martin Entlicher 2009-05-04 10:48:16 UTC
*** Issue 163360 has been marked as a duplicate of this issue. ***
Comment 4 gholmer 2009-05-06 13:49:51 UTC
I have seen this issue also.
Comment 5 Martin Entlicher 2009-05-12 15:54:20 UTC
*** Issue 164800 has been marked as a duplicate of this issue. ***
Comment 6 Martin Entlicher 2009-05-13 08:45:43 UTC
*** Issue 164802 has been marked as a duplicate of this issue. ***
Comment 7 Filip Zamboj 2009-05-18 13:59:57 UTC
@reporter: we need some steps to reproduce, I'm really not able to find out when this happens. 
Comment 8 Martin Entlicher 2009-05-19 15:30:03 UTC
Reproduced while debugging NetBeans:
1) Start NetBeans in debug mode (with -J-Xdebug -J-Xrunjdwp:transport=dt_socket,server=y,suspend=n,address=.... arguments)
2) Start another NetBeans with different user directory.
3) Open main/openide.nodes/src/org/openide/nodes/Node.java and submit breakpoint at line 1224 in NetBeans started in 2)
4) Attach to NetBeans 1)
5) In NetBeans 1) click on New Project...
6) Breakpoint is hit, assure Variables window is visible and run Continue several times till Continue is disabled.
Comment 9 Vladimir Voskresensky 2009-05-19 16:25:21 UTC
I'm sorry, I can not give you reproducible scenario, but I can run IDE with any flags/loggers you are interested in to
catch. What should I turn on?
Comment 10 Martin Entlicher 2009-05-20 12:51:18 UTC
Hopefully fixed by changeset:   132559:a67a17e9b2d1
http://hg.netbeans.org/main/rev/a67a17e9b2d1

Please verify.
Comment 11 Quality Engineering 2009-05-21 08:30:43 UTC
Integrated into 'main-golden', will be available in build *200905210201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/a67a17e9b2d1
User: mentlicher@netbeans.org
Log: #160747 - Assure that thread events are fired.
Comment 12 krahe 2009-07-09 21:56:48 UTC
Happens to me quite regularly on Windows 2000 SP4 with NB Release 6.7 running on JDK 1.6.0_14.
Comment 13 carloscorreia 2009-07-27 00:27:28 UTC
The problem persists in Build 200906241340, in Linux with Java 1.6.

Java:
java version "1.6.0_14"
Java(TM) SE Runtime Environment (build 1.6.0_14-b08)
Java HotSpot(TM) Client VM (build 14.0-b16, mixed mode, sharing)

OS:
Kubuntu 8.04
Kernel: 2.6.24-24-generic
Comment 14 Martin Entlicher 2009-07-31 16:54:16 UTC
Problem on JDK 6 Update 14 might be duplicate of issue #166579 - likely caused by JDK issue.

The fix applied here didn't fix fully the problem - since there's newer issue #167776 with the same symptoms.

Since issue #167776 has a higher priority, we'll continue with the resolution there... therefore I'm marking this as a
duplicate.
If you have some at least partially reliable steps how this can be reproduced, please provide them here on into issue
#167776. Thanks.

*** This issue has been marked as a duplicate of 167776 ***
Comment 15 Martin Entlicher 2009-07-31 17:03:00 UTC
Also please note that there's issue #166579, which is likely jdk6u14-specific. Do you encounter problems with Continue
even on older JDKs or with "-J-XX:+UseParallelGC" option added to NetBeans?
Comment 16 Quality Engineering 2010-04-29 09:49:24 UTC
Verified ... and Closing all issues resolved into NetBeans 6.7 and earlier.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo