Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 160602 - Fix imports NullPointerException in default package
Fix imports NullPointerException in default package
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: Editor
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Max Sauer
issues@java
: NETFIX
: 160002 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-18 23:55 UTC by fommil
Modified: 2009-05-07 10:35 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Proposed fix against recent main-golden (932 bytes, patch)
2009-03-18 23:55 UTC, fommil
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description fommil 2009-03-18 23:55:09 UTC
I stumbled upon this little bug in a recent main-golden when trying to implement an RFE... if Fix Imports is invoked on a class which is in the default package, 
a NullPointerException is raised.

Proposed fix attached (soon).
Comment 1 fommil 2009-03-18 23:55:45 UTC
Created attachment 78418 [details]
Proposed fix against recent main-golden
Comment 2 Max Sauer 2009-03-30 11:25:03 UTC
Thanks for filing this issue and patch, integrated.
---
http://hg.netbeans.org/jet-main/rev/7cb5d4e0768c
Comment 3 Quality Engineering 2009-03-31 07:35:20 UTC
Integrated into 'main-golden', will be available in build *200903310200* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/7cb5d4e0768c
User: Max Sauer <msauer@netbeans.org>
Log: #160602: Fix imports NullPointerException in default package
Comment 4 fommil 2009-04-04 02:02:12 UTC
Should I have commented the empty String with NOI18N?
Comment 5 Max Sauer 2009-04-06 09:11:45 UTC
Not necessary IMHO, thanks.
Comment 6 Max Sauer 2009-04-10 10:01:21 UTC
*** Issue 160002 has been marked as a duplicate of this issue. ***
Comment 7 fommil 2009-04-22 21:16:50 UTC
claiming in the name of NetFIX ;-)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo