Bug 160583 - NullPointerException at org.netbeans.modules.mercurial.ui.wizards.ClonePathsPanel.isValid
NullPointerException at org.netbeans.modules.mercurial.ui.wizards.ClonePathsP...
Status: RESOLVED DUPLICATE of bug 157898
Product: versioncontrol
Classification: Unclassified
Component: Mercurial
6.x
All All
: P3 (vote)
: TBD
Assigned To: issues@versioncontrol
issues@versioncontrol
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-18 19:27 UTC by vertmont
Modified: 2009-03-18 20:13 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.51 KB, text/plain)
2009-03-18 19:27 UTC, vertmont
Details

Note You need to log in before you can comment on or make changes to this bug.
Description vertmont 2009-03-18 19:27:47 UTC
Build: NetBeans IDE 6.5.1 (Build 200903060201)
VM: Java HotSpot(TM) Client VM, 11.2-b01, Java(TM) SE Runtime Environment, 1.6.0_12-b04
OS: Windows XP, 5.1, x86

User Comments:
vertmont: I've installed the latest version of Mercurial - 1.2 in the standard location on XP.
I select Versioning > Mercurial > Clone Other
I don't get any windows opening but I did get this exception.

I was trying to get the NetBeans src.

Dan

GUEST: newbie attempting to synchronise with a mercurial repository which requires a login (user/password).

GUEST: I tried to check out a project using Mercurial using "Versioning" --> "Mercurial" when the Exception occured. No project was open at the time.

GUEST: Direkt nach dem Starten der IDE die Funktion "Versionsverwaltung => Mercurial => Von Fremdquelle clonen" ausw�hlen.

GUEST: Trying to clone hg repository. Before installed TortoiseHG, Mercurial Version is 1.1.2

moser: tried to invoke Versioning > Mercurial > Clone Other

GUEST: Attempting to clone a repository.

GUEST: Trying to import a project from a mecurial repo

GUEST: trying to clone a mercurial repository

rusexton: When running NetBeansIDE 6.5 with java version "1.6.0_0"
IcedTea6 1.3.1 (6b12-0ubuntu6.1) Runtime Environment (build 1.6.0_0-b12)
OpenJDK 64-Bit Server VM (build 1.6.0_0-b12, mixed mode)
I have no problems running anything.

But!!!!!! 

When running NetBeansIDE 6.5 with java version "1.6.0_12"
Java(TM) SE Runtime Environment (build 1.6.0_12-b04)
Java HotSpot(TM) 64-Bit Server VM (build 11.2-b01, mixed mode)

After choosing from the main menu Versioning > Mercurial > Clone Other... I get this exception.

GUEST: I tried to clone a Mercurial, and i get this message.

GUEST: I've got this when I click on Versionig -> Mercurual -> Clone Other

GUEST: Just installed Mercurial 1.1.2, then installed NB 6.5, and then clicked MenuItem Versioning->Clone others ... 
That was all what i did.

tkrd_oiax: Tried to clone with Mercurial.

marciolopes: I tried to clone a mercurial repositorie, and i get this message error.
I have the latest version of Netbeans (6.5)

sflemming: Clicked Versioning->Mercurial->Clone other. 
HG 1.1.2 from Tortoise HG package installed.
Same problem with Windows 7 beta built 7000.

bmm: Cloning Mercurial Repo

squalyl: just clicked the "versioning->mercurial->clone" menu option :(

GUEST: Versioning/Mercurial/Clone other..

Nothing happens except this error message.

GUEST: This problem does not happen in the 64 bit version of Windows 7 @ my desktop, at least no to me, and its the same latest version of the plugin.

I'm running currently on an Acer One A150, Windows 7 build 7000 32 bits.

mathewboorman: Selected menu option to clone a Mercurial repo.

This is a fresh box all new installs:

- NB6.5 install on Vista, jdk 6.
- got all updates (including a mercurial change)
- installed TortoiseHg (no reboot)
- restarted NB so it picks up path updates.

rusexton: I chose from the main menu bar 
      Versioning > Mercurial > Clone Other ...
and boom this exception.



Stacktrace: 
java.lang.NullPointerException
        at org.netbeans.modules.mercurial.ui.wizards.ClonePathsPanel.isValid(ClonePathsPanel.java:77)
        at java.awt.Component.invalidateIfValid(Component.java:2740)
        at java.awt.Component.setLocale(Component.java:1810)
        at javax.swing.JComponent.<init>(JComponent.java:595)
        at javax.swing.JPanel.<init>(JPanel.java:65)
        at javax.swing.JPanel.<init>(JPanel.java:92)
Comment 1 vertmont 2009-03-18 19:27:56 UTC
Created attachment 78403 [details]
stacktrace
Comment 2 Ondrej Vrabec 2009-03-18 20:13:25 UTC

*** This issue has been marked as a duplicate of 157898 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo