Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 160502 - [69cat][68cat][ruby][scanning] Cannot delete file rake-d.txt when scanning project
[69cat][68cat][ruby][scanning] Cannot delete file rake-d.txt when scanning pr...
Status: RESOLVED FIXED
Product: ruby
Classification: Unclassified
Component: Rake
6.x
PC All
: P3 (vote)
: 6.x
Assigned To: Erno Mononen
issues@ruby
: NETFIX
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-17 22:02 UTC by esmithbss
Modified: 2010-04-28 05:05 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
log file. (75.37 KB, text/plain)
2009-03-17 22:04 UTC, esmithbss
Details
6.8 Log File with exception generated. (60.54 KB, text/plain)
2009-10-23 04:46 UTC, esmithbss
Details
6.9 (201003170201) log file where error was displayed (67.89 KB, application/octet-stream)
2010-03-19 08:17 UTC, esmithbss
Details
6.9 (201003170201) Log file from crash which preceeded this bug's reappearance (72.45 KB, application/octet-stream)
2010-03-19 08:17 UTC, esmithbss
Details
Zipped project folder for entire project which is now generating the exception (866.80 KB, application/zip)
2010-03-19 08:19 UTC, esmithbss
Details

Note You need to log in before you can comment on or make changes to this bug.
Description esmithbss 2009-03-17 22:02:34 UTC
Upon loading an existing project into NB 6.5.1 or greater, I receive a message "Cannot delete file rake-d.txt in
<project_dir>/nbproject/private.

The file was created by NB 6.5.1 earlier today, it exists in the folder, and is able to be deleted outside of NB without
trouble.

It appears that this error may be masking the underlying SVNClientException which may be the underlying cause of the
problem.

This initially occurred with the default 6.5.1 install and it also occurs with the latest subversion plugin.

The subversion client is the newest subversion client (1.5) and the subversion repository is ver 1.4.
Comment 1 esmithbss 2009-03-17 22:04:41 UTC
Created attachment 78329 [details]
log file.
Comment 2 Erno Mononen 2009-03-18 08:56:45 UTC
Right, seems to be some kind of a problem with the SVN client and NB. I'll see what can be done on the IDE side.
Comment 3 Erno Mononen 2009-05-19 15:54:57 UTC
Unfortunately can't do anything about this for 6.7, has to wait for the next release.
Comment 4 esmithbss 2009-10-18 04:43:13 UTC
This issue vanished until 200910161401.  Now, when I have an SVN based project loaded, then close the IDE, when I reload
the IDE, this message pops up while scanning the application.

So one of the changes between 200910140201 and 200910161401 re-introduced this issue.
Comment 5 esmithbss 2009-10-18 05:20:26 UTC
I added the tags to the name to indicate this has been encountered during NetCat 6.8.  
Comment 6 esmithbss 2009-10-23 04:46:54 UTC
Created attachment 89950 [details]
6.8 Log File with exception generated.
Comment 7 esmithbss 2009-10-23 05:08:04 UTC
I concur that this is an issue with SVN client.  I removed all .svn folders from my project and the project vanished. 
Removing the .svn folders is not a viable work around.  Viable work around is to manually delete the file before opening
NetBeans or if NB is open, manually delete the file then open the "Run/Debug Rake Task" item and click the Refresh Tasks
button.
Comment 8 esmithbss 2010-03-19 08:11:01 UTC
This just cropped up in a project which was fine until the IDE locked up during debugging.

As I was debugging a test within the project, I expanded the errors hash in the variables window.

After expanding the hash, the system became unresponsive.  Eventually I had to kill the debugging process.

While I killed the debugging process and the IDE detached, it did not correct the 100% CPU usage which continued for many minutes after killing the debugging process.  After 3-5 minutes, the computer crashed.  It appears that this was before the IDE had time to finish any end-of-debug process cleanup on the project file.

Following a reboot of the machine and a reload of the project into the IDE, this error appears during project scanning.
Comment 9 esmithbss 2010-03-19 08:13:23 UTC
This latest occurrance has nothing to do with subversion or any VCS client.  The project was created within NetBeans 201003170201 and has only been worked on using this IDE version.  

There were 3 projects open in the IDE at the time; however, none of them are currently under version control and only the project that is now failing is generating this error.
Comment 10 esmithbss 2010-03-19 08:17:00 UTC
Created attachment 95412 [details]
6.9 (201003170201) log file where error was displayed
Comment 11 esmithbss 2010-03-19 08:17:49 UTC
Created attachment 95413 [details]
6.9 (201003170201) Log file from crash which preceeded this bug's reappearance
Comment 12 esmithbss 2010-03-19 08:19:14 UTC
Created attachment 95414 [details]
Zipped project folder for entire project which is now generating the exception
Comment 13 Erno Mononen 2010-03-19 17:15:13 UTC
Thanks for the project, I'll give this a try.
Comment 14 ehartmann 2010-04-06 12:45:14 UTC
I've tried to reproduce this with the project attached. 
But I have no exception with today build.
I've tried the following scenarii :
* Open it with my current projects => OK
* Closing Netbeans and reopening netbeans => OK
* Removing all my projects but the attached project => OK

Can you try to open your project with a newer build to know if this bug is still present ?

Thank you.

-éric
Comment 15 Jiri Kovalsky 2010-04-26 18:40:11 UTC
Erno, any update on this? Thanks!
Comment 16 Erno Mononen 2010-04-27 14:39:06 UTC
I wasn't able to reproduce, but I did spot a probable cause for this and fixed that in 2ff60085e8b5. Likely the problem was caused by trying to delete a file that was already deleted; the fix was adding a simple check for FileObject#isValid.
Comment 17 Quality Engineering 2010-04-28 05:05:31 UTC
Integrated into 'main-golden', will be available in build *201004280200* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/
User: 
Log:


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo