Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 160372 - Really bad performence in "Go to File" function with projects on samba shares
Really bad performence in "Go to File" function with projects on samba shares
Status: RESOLVED DUPLICATE of bug 122639
Product: utilities
Classification: Unclassified
Component: Jump To
6.x
All All
: P1 (vote)
: TBD
Assigned To: Andrey Yamkovoy
Jiri Prox
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-16 16:11 UTC by darkvamp1976
Modified: 2009-03-17 17:58 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description darkvamp1976 2009-03-16 16:11:32 UTC
If I use the "Go to File" function in a big project (more than 1500 files) AND the files are located on a samba share on 
our linux server the performence IS REALLY REALLY BAD !

The Option "Put NetBeans metadata into a seprate directory" is checked so I hoped the samba share isn´t a performence 
factor in "Go to File" functions :-(
Comment 1 Tomas Pavek 2009-03-17 17:58:24 UTC
Go to File goes through the files sequentially, so that's likely why it is so slow. There is no index for files in 
metadata, so having userdir on local disk does not help here.

There is still a chance we'll have the index for Go to File implemented for NB 6.7, see issue 122639. That would make 
it significantly faster.

Note that in case you are looking for classes, you can use Go to Type (Ctrl+O) which should perform much better.

*** This issue has been marked as a duplicate of 122639 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo