Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 160174 - NPE on ide exit
NPE on ide exit
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: Parsing & Indexing
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Dusan Balek
issues@editor
:
: 160480 162016 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-12 12:44 UTC by Petr Hejl
Modified: 2009-04-10 07:36 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Hejl 2009-03-12 12:44:02 UTC
Exiting IDE while scanning.

java.lang.NullPointerException
	at org.netbeans.modules.java.source.indexing.JavaParsingContext.<init>(JavaParsingContext.java:68)
	at org.netbeans.modules.java.source.indexing.JavaCustomIndexer$1$1.run(JavaCustomIndexer.java:100)
	at org.netbeans.modules.java.source.indexing.JavaCustomIndexer$1$1.run(JavaCustomIndexer.java:96)
	at org.netbeans.modules.java.source.tasklist.TaskCache.refreshTransaction(TaskCache.java:464)
Caused: java.io.IOException
	at org.netbeans.modules.java.source.tasklist.TaskCache.refreshTransaction(TaskCache.java:468)
	at org.netbeans.modules.java.source.indexing.JavaCustomIndexer$1.run(JavaCustomIndexer.java:96)
	at org.netbeans.modules.java.source.indexing.JavaCustomIndexer$1.run(JavaCustomIndexer.java:94)
	at org.netbeans.modules.java.source.usages.ClassIndexManager.writeLock(ClassIndexManager.java:100)
[catch] at org.netbeans.modules.java.source.indexing.JavaCustomIndexer.index(JavaCustomIndexer.java:94)
	at org.netbeans.modules.parsing.spi.indexing.Indexable$MyAccessor.index(Indexable.java:141)
	at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Work.index(RepositoryUpdater.java:618)
	at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$FileListWork.getDone(RepositoryUpdater.java:712)
	at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Work.doTheWork(RepositoryUpdater.java:654)
	at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Task._run(RepositoryUpdater.java:1078)
	at org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$Task.run(RepositoryUpdater.java:1054)
	at org.netbeans.modules.parsing.impl.TaskProcessor$CompilationJob.run(TaskProcessor.java:599)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
	at java.util.concurrent.FutureTask.run(FutureTask.java:138)
	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
	at java.lang.Thread.run(Thread.java:619)
Comment 1 Rastislav Komara 2009-03-25 15:50:16 UTC
Reassigning to proper component for re-evaluation. I can't reproduce this in current jet-main repository. 
Comment 2 Rastislav Komara 2009-03-25 16:19:12 UTC
*** Issue 160480 has been marked as a duplicate of this issue. ***
Comment 3 Jiri Prox 2009-04-07 15:46:42 UTC
*** Issue 162016 has been marked as a duplicate of this issue. ***
Comment 4 Dusan Balek 2009-04-09 09:34:10 UTC
Fixed in jet-main.

http://hg.netbeans.org/jet-main/rev/a7563fc7a483
Comment 5 Quality Engineering 2009-04-10 07:36:29 UTC
Integrated into 'main-golden', will be available in build *200904100201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/a7563fc7a483
User: Dusan Balek <dbalek@netbeans.org>
Log: Issue #160174: NPE on ide exit - fixed.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo