Bug 159930 - netbeans.winsys.statusLine.in.menuBar=true no longer works
netbeans.winsys.statusLine.in.menuBar=true no longer works
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Window System
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Jaroslav Tulach
issues@platform
: REGRESSION, THREAD
Depends on:
Blocks: 30121
  Show dependency treegraph
 
Reported: 2009-03-09 17:29 UTC by Jesse Glick
Modified: 2009-03-18 22:47 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Proposed patch (2.27 KB, patch)
2009-03-13 16:58 UTC, Jaroslav Tulach
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2009-03-09 17:29:07 UTC
Between b74ae26eeefb and 38ea4c96b37b, using this flag produces:

java.lang.AssertionError: Must run in AWT queue.
	at org.netbeans.core.windows.view.ui.MainWindow.decoratePanel(MainWindow.java:236)
	at org.netbeans.core.windows.view.ui.MainWindow.createMenuBar(MainWindow.java:387)
	at org.netbeans.core.windows.view.ui.MainWindow.init(MainWindow.java:142)
	at org.netbeans.core.windows.WindowSystemImpl.init(WindowSystemImpl.java:68)
	at org.netbeans.core.NonGui.initializeMainWindow(NonGui.java:169)
	at org.netbeans.core.NonGui.run(NonGui.java:104)
	at org.netbeans.core.startup.Main.start(Main.java:319)
	at org.netbeans.core.startup.TopThreadGroup.run(TopThreadGroup.java:110)
	at java.lang.Thread.run(Thread.java:619)

and the IDE exits.
Comment 1 Jesse Glick 2009-03-10 15:35:51 UTC
BTW this flag's main purpose is to avoid wasting a bunch of vertical screen space on a status line which is usually
empty and even when not empty can usually fit comfortably into the otherwise blank area to the right of the menus. In
practice this translates to an extra line or two of editor text, which is significant on a laptop.
Comment 2 Stanislav Aubrecht 2009-03-13 16:29:44 UTC
caused by jarda's fix of #30121
Comment 3 Jaroslav Tulach 2009-03-13 16:58:26 UTC
Created attachment 78154 [details]
Proposed patch
Comment 4 Jaroslav Tulach 2009-03-13 17:00:22 UTC
I would fix this using the above patch. Imho it is safe to construct components outside of AWT before the main window 
is shown. But I'd rather let it for Standa to accept or reject this change.
Comment 5 Jesse Glick 2009-03-13 17:07:17 UTC
Last I remember, making AWT comps outside of EQ is never safe, even if no window has yet been shown.
Comment 6 Stanislav Aubrecht 2009-03-13 17:33:33 UTC
well, very recently i was fixing a couple of deadlocks because swing components were created/accessed outside AWT thread.

can't we create the main window in AWT thread?
Comment 7 Stanislav Aubrecht 2009-03-16 13:34:41 UTC
alright, go ahead and integrate the patch. if the main window isn't visible yet then the risk is low
Comment 8 Jaroslav Tulach 2009-03-16 16:10:55 UTC
core-main#e6f192991faa
Comment 9 Quality Engineering 2009-03-18 22:47:16 UTC
Integrated into 'main-golden', will be available in build *200903181604* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/e6f192991faa
User: Jaroslav Tulach <jtulach@netbeans.org>
Log: #159930: Integrating patch as S. Aubrecht suggested. Mainwindow can be created outside of AWT initially.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo