Bug 159746 - Cannot get the correct record num and pages number.
Cannot get the correct record num and pages number.
Status: RESOLVED INVALID
Product: db
Classification: Unclassified
Component: Show Data
6.x
PC Windows XP
: P3 (vote)
: 6.x
Assigned To: Jiri Rechtacek
issues@db
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-06 06:07 UTC by rickqin
Modified: 2009-09-16 12:17 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rickqin 2009-03-06 06:07:07 UTC
1. When I execute GROUP BY sql in db explorer, the DBExplorer cannot show a correct num of records, usually display N/A.
2. Forbid to commit changes in the datagrid(the area with a guide bar and to show out the result of execution of query
sql above.) with result from GROUP BY sql operation. It will cause a serious data confusing.
3. sometimes, executing recursive sql (maybe a subquery, i dont how to say that) will fill in datagrid with many blank
records and pages.
Comment 1 Jiri Rechtacek 2009-08-21 17:00:00 UTC
I'm sorry for a late response. But I'm afraid I don't understand the problems. Could you attach steps to reproduce each
of problems? In future, please file separate issue for each of them. Thanks
Comment 2 martinhavle 2009-08-24 13:41:55 UTC
1. Works for me on build 200908221401 with JDK6u14 on Ubuntu 9,04. Can you please specify how to reproduce the issue?
2. Don't see any problem. Until you commit changhes to DB, data stays unchanged. That is the way how the SQL language works.
3. Can you, please, give an example of query, where the problem occurs? I am not able to reproduce it.
Comment 3 rickqin 2009-09-16 12:17:53 UTC
it's been solved in 6.7 edition or above.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo