Bug 159722 - Full File Name Path shown in the Title Bar
Full File Name Path shown in the Title Bar
Status: RESOLVED WONTFIX
Product: platform
Classification: Unclassified
Component: Text
6.x
All All
: P3 with 9 votes (vote)
: TBD
Assigned To: issues@editor
issues@editor
issue_reviewed
:
: 122223 161636 178091 178603 196153 204559 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-05 21:05 UTC by kidvid
Modified: 2015-05-09 12:37 UTC (History)
10 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kidvid 2009-03-05 21:05:58 UTC
A great enhancement would be to show the full file name path in the title bar of NetBeans, for whatever file's tab is
active, or put another way, for the current file being edited.  

I read through the 6.7 change list and it looks like some work is being done to accommodate the current file being
selected on the Files tab, but this would take it a step further and make it much easier to quickly determine where the
file is on the disk, without needing any extra clicks.

Additionally, this is a common feature in other development tools.

An example of how the title bar would read:

"MY SERVER PROJECT - NetBeans IDE 6.5  [D:\Java Code\My Code\src\com\mycompany\utils\file\FileManager.Java]"
Comment 1 rkite 2009-07-06 20:54:01 UTC
Putting the currently selected files directory path in the title bar is very useful.  We have numerous source paths in
our project which makes it hard to tell what you are working on in NetBeans.  This simple feature makes it much easier
to tell where the file is when editing.  The old JBuilder 2006 IDE had this feature.  Simple easy to implement and very
useful.  
Comment 2 Marian Mirilovic 2010-04-19 08:52:41 UTC
The full path is available in tooltip over titlebar in the editor. What I really miss is the way to divide opened editors to particular projects, but have no idea how it could be organized ...
Comment 3 Michel Graciano 2010-04-19 18:51:58 UTC
*** Bug 161636 has been marked as a duplicate of this bug. ***
Comment 4 Fishdrowned 2011-03-22 07:07:00 UTC
*** Bug 178091 has been marked as a duplicate of this bug. ***
Comment 5 MaWoe 2011-04-08 20:18:53 UTC
I fully agree to my predecessors. Netbeans is great! I used Eclipse PDT 2 for months and was so annoyed by myriads of bugs and missing important features. Yet this one silly thing is missing in Netbeans and I think it would increase usability enormously at least for some of us.
Comment 6 faheemhameed 2011-07-21 10:34:49 UTC
I very much need this improvement. It would save me confusions and a lot of time especially when I am working with a lot of files which are same name (different folder names though)

Thanks for giving this bug a much higher priority. Thanks for your great work!!
Comment 7 fr0sty 2011-07-21 15:35:42 UTC
I also would like to see this enhancement
Comment 8 ptacek.pavel 2011-12-06 00:46:39 UTC
Well, my point of view is for people like me, who are using Paymo (www.paymo.biz) or other title-reading software like rescue time.

The point is further billing: currently I see in the list of apps & time spent there, only the title of the project and I cannot distinguish between the individual tasks.

If there would be an title of currently open file, that would made our lifes easier.
Comment 9 wyred 2011-12-22 10:02:08 UTC
I would love to have this enhancement.

Some of my projects have the same filenames but in different folders. I often cannot tell which file I'm viewing/editing.

Having to mouseover the tab each time just to find out the filename makes us less productive.

Having to keep a properties panel open just to see the full path takes up precious screen property, especially when working on a laptop.
Comment 10 markiewb 2012-02-27 06:24:15 UTC
*** Bug 196153 has been marked as a duplicate of this bug. ***
Comment 11 markiewb 2012-02-27 06:27:15 UTC
*** Bug 204559 has been marked as a duplicate of this bug. ***
Comment 12 markiewb 2012-02-27 06:32:51 UTC
It can be easily implemented the following way. (It works for me, but i am not sure if it works in all cases. I am not a netbeans platform guru.) 

I will provide a module in a few days, so that you do not have to wait for the next release...

package org.foo;

import java.beans.PropertyChangeEvent;
import java.beans.PropertyChangeListener;
import org.openide.filesystems.FileUtil;
import org.openide.loaders.DataObject;
import org.openide.modules.ModuleInstall;
import org.openide.windows.TopComponent;
import org.openide.windows.WindowManager;

/**
 * Shows the path of the current {@link DataObject} in the title of the main
 * window.
 *
 * @author markiewb
 */
public class Installer extends ModuleInstall {

    private static final long serialVersionUID = -2422104143131463778L;

    @Override
    public void validate() throws IllegalStateException {
        TopComponent.getRegistry().addPropertyChangeListener(new PropertyChangeListener() {

            @Override
            public void propertyChange(PropertyChangeEvent evt) {
                TopComponent activeTC = TopComponent.getRegistry().getActivated();
                if (null == activeTC) {
                    return;
                }
                DataObject lookup = activeTC.getLookup().lookup(DataObject.class);

                String title;
                if (null != lookup) {
                    // if it is a file then get the absolute path
                    title = FileUtil.toFile(lookup.getPrimaryFile()).getAbsolutePath();
                } else {
                    //else get the name
                    String result = activeTC.getDisplayName();
                    title = (result != null ? result : activeTC.getDisplayName());
                }
                WindowManager.getDefault().getMainWindow().setTitle(title);
            }
        });
    }
}
Comment 13 markiewb 2012-02-28 23:16:25 UTC
(In reply to comment #12)
> I will provide a module in a few days, so that you do not have to wait for the
> next release...

See http://code.google.com/p/show-path-in-title-netbeans-module/
Comment 14 arthur24b6 2012-03-26 13:04:24 UTC
Confirming that markiewb's plugin works form me on 6.9.1
Comment 15 blakenzoe 2012-03-26 22:16:44 UTC
I've also verified that this works with .php, .css, .js, .yml, .ini files on 7.1

I cannot tell you how excited I am for this plugin...previously, the lack of an all-time visual indicator of full file path has been a HUUUGE pain in the behind for me.  This limitation alone has prevented me from adopting NetBeans over both Eclipse and JetBrains' new PHPStorm. Try opening 75 "index.php" files and making sure you don't inadvertently edit the wrong one. This plugin helps immensely.
Comment 16 markiewb 2012-05-05 13:37:02 UTC
The plug(In reply to comment #13)
> (In reply to comment #12)
> > I will provide a module in a few days, so that you do not have to wait for the
> > next release...
> 
> See http://code.google.com/p/show-path-in-title-netbeans-module/

The plugin is noew also available at "NetBeans Plugin Center" - http://plugins.netbeans.org/plugin/42000 AND available via "NetBeans Update Center" within your IDE.
Comment 17 markiewb 2012-09-22 23:16:46 UTC
*** Bug 122223 has been marked as a duplicate of this bug. ***
Comment 18 markiewb 2012-09-22 23:30:32 UTC
*** Bug 178603 has been marked as a duplicate of this bug. ***
Comment 19 naitsirch 2012-10-17 06:23:40 UTC
@markiewb the plugin works well. Thank you very much for your work!
But of course it would be nice if this functionality will be included into Netbeans Core.
Comment 20 markiewb 2013-03-04 22:01:58 UTC
*** Bug 220078 has been marked as a duplicate of this bug. ***
Comment 21 sam63 2014-01-28 15:30:57 UTC
Well,  you can use Long Path Tool for such issues.
Comment 22 naitsirch 2014-03-20 11:18:48 UTC
In Netbeans 8.0 you can find the option 'Show full file path' in Tools -> Options -> Appearance -> Document Tabs

If you check this option, The full path of the activated tab is shown between tab panel and editor.
Comment 23 markiewb 2015-05-09 12:37:04 UTC
Resolve as wontfix because there is a 3rd party plugin for that.

http://plugins.netbeans.org/plugin/42000


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo