Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 159622 - Failing tests
Failing tests
Status: RESOLVED FIXED
Product: javaee
Classification: Unclassified
Component: EAR
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Jaroslav Tulach
issues@javaee
: TEST
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-04 16:42 UTC by Petr Hejl
Modified: 2009-03-25 21:19 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
j2ee.earproject tests seem to work fine now (394.85 KB, application/x-compressed)
2009-03-10 11:09 UTC, Jaroslav Tulach
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Hejl 2009-03-04 16:42:27 UTC
Almost all tests in EAR (and perhaps EJB and Web as well) are failing.
Comment 1 David Konecny 2009-03-04 21:07:38 UTC
Are they? I just run web, ejb, and ear tests (on week or two old trunk sources) and most of them pass. Each module has
about three failing tests but as far as I remember these were always failing. That's WORKSFORME. :-)
Comment 2 David Konecny 2009-03-09 03:59:09 UTC
After update to lastest sources I can reproduce the problem. Basically all project tests (web, j2se, ...) fail now
because AntBasedProjectType cannot be found. I believe it is regression caused by issue 153655 by Jarda. I'm increasing
to P1 priority because after couple of hours I could not resolve the problem and because it blocks integration of my M3
work. I could work around it by calling AntBasedProjectFactorySingleton.create() which could be acceptable solution
inside project type tests but I do not want to copy and paste it to other project agnostic tests (eg. JSP editor tests
which need Java classpath which in turn is provided by Web Project)
Comment 3 Jaroslav Tulach 2009-03-09 12:42:49 UTC
Please list names of modules with broken tests. I am going to fix web.project, but tell me what all I shall fix. 
Thanks.
Comment 4 Jaroslav Tulach 2009-03-09 13:55:44 UTC
Improved in
http://hg.netbeans.org/ergonomics/rev/f4aeb4515e7e
please get inspired or let me know what else shall I fix.
Comment 5 David Konecny 2009-03-09 20:53:15 UTC
Thanks I will have a look at the fix in a moment. The modules I know are failing are: web.project and java.j2seproject.
This issue originally mentions that j2ee.ejbjarproject and j2ee.earproject are failing as well. Considering the type of
your change - moving items from one lookup to the other - all project types which you've changed and which has some
basic unit tests for project creation are broken.
Comment 6 Quality Engineering 2009-03-10 09:26:26 UTC
Integrated into 'main-golden', will be available in build *200903100201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/f4aeb4515e7e
User: Jaroslav Tulach <jtulach@netbeans.org>
Log: #159622: Fixing tests apperently failing due to use of @AntBaseProjectRegistration
Comment 7 Jaroslav Tulach 2009-03-10 10:27:26 UTC
java.j2seproject tests improved in core-main#9d2fb1de3fb2

Btw. it might help in cases where tests don't mangle with lookup at all, if we change Lookup.getDefault() to include 
Lookups.forPath("Services") by default...
Comment 8 Jaroslav Tulach 2009-03-10 11:09:16 UTC
Created attachment 77963 [details]
j2ee.earproject tests seem to work fine now
Comment 9 Jaroslav Tulach 2009-03-10 14:07:27 UTC
j2ee.ejbjarproject tests fixed in core-main#f656fb10a66f
I guess as soon as the changes propagate, the known failures caused by @AntProjectBasedRegistration will be fixed.
Comment 10 Jesse Glick 2009-03-10 14:34:38 UTC
BTW if j2seproject owner(s) would fix their unit tests to all actually pass - last I checked there were open DEFECTs
about tests known to fail - we would include this module in core-main's test suite, which would catch this kind of
regression much earlier. Currently project.ant and similar infrastructure is tested, even ant.freeform & java.freeform,
but not java.j2seproject pending a stable set of tests.
Comment 11 Jan Jancura 2009-03-10 15:26:56 UTC
I will look at our tests. Thanks.
Comment 12 Jaroslav Tulach 2009-03-10 16:17:39 UTC
The more stable tests to run, the better. Btw. those tests are executed, just not part of commit validation: 
http://ruhudson4qe.russia/job/j2seproject/
Comment 13 Jesse Glick 2009-03-10 16:23:31 UTC
I wasn't proposing inclusion of java.j2seproject tests in "commit validation" as such, just core-main's suite. It makes
sense to run it there because changes to project.ant often affect tests in Ant-based project types (or even include
patches to java.j2seproject), and in my experience a developer making such changes would usually want to check for
regressions in j2seproject as a representative project type. Some of the tests are fairly slow, BuildImplTest in
particular, but then again many platform test suites are slow.
Comment 14 Quality Engineering 2009-03-11 22:49:17 UTC
Integrated into 'main-golden', will be available in build *200903111543* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/9d2fb1de3fb2
User: Jaroslav Tulach <jtulach@netbeans.org>
Log: #159622: Fixing java.j2seproject tests by making sure that MockLookup includes also content of Lookups.forPath('Services').
Comment 15 Quality Engineering 2009-03-25 21:19:04 UTC
Integrated into 'main-golden', will be available in build *200903251400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/78ae9b2b84ff
User: Richard Michalsky <rmichalsky@netbeans.org>
Log: #159622: fixing tests in o.n.m.apisupport.project.layers


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo