Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 159584 - Unable to launch Generate due to NPE
Unable to launch Generate due to NPE
Status: RESOLVED DUPLICATE of bug 157326
Product: ruby
Classification: Unclassified
Component: Rails
6.x
PC Linux
: P3 (vote)
: 6.x
Assigned To: Erno Mononen
issues@ruby
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-04 07:46 UTC by esmithbss
Modified: 2009-03-04 07:53 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
ide log file (60.83 KB, text/plain)
2009-03-04 07:47 UTC, esmithbss
Details

Note You need to log in before you can comment on or make changes to this bug.
Description esmithbss 2009-03-04 07:46:55 UTC
Following an update of my plugins on 3/3/09, and the reboot of the IDE, I cannot run a Generate command and receive a
dialog.

The exception is:

SEVERE [org.openide.util.RequestProcessor]
java.lang.NullPointerException
        at org.netbeans.modules.ruby.railsprojects.GeneratorPanel.getSelectedGenerator(GeneratorPanel.java:143)
        at org.netbeans.modules.ruby.railsprojects.GeneratorPanel.isValid(GeneratorPanel.java:480)
        at java.awt.Component.invalidateIfValid(Component.java:2740)
        at java.awt.Component.setLocale(Component.java:1810)
        at javax.swing.JComponent.<init>(JComponent.java:595)
...

IDE Log attached for more detail.
Comment 1 esmithbss 2009-03-04 07:47:27 UTC
Created attachment 77687 [details]
ide log file
Comment 2 Erno Mononen 2009-03-04 07:53:41 UTC
This is a known issue with JDK 6u12, it broke many things in the IDE. These issues are fixed 6.5.1 (will be release 
soon I think) and 6.7 M2, with 6.5 you have to use JDK6u11 or older.

*** This issue has been marked as a duplicate of 157326 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo