Bug 15953 - NullPointerException when resizing OutputWindow with selected text
NullPointerException when resizing OutputWindow with selected text
Status: CLOSED FIXED
Product: cnd
Classification: Unclassified
Component: Terminalemulator
3.x
Sun Solaris
: P3 (vote)
: 6.x
Assigned To: ivan
ivan
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-27 09:22 UTC by Jiri Skrivanek
Modified: 2008-12-23 08:26 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Stack trace (2.68 KB, text/plain)
2001-09-27 09:23 UTC, Jiri Skrivanek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Skrivanek 2001-09-27 09:22:15 UTC
Tested in build 20010925-2334, JDK1.3.1.

- select whole content of the OutputWindow
- resize OW to be smaller
- you get NPE

java.lang.NullPointerException
        at org.netbeans.lib.terminalemulator.Buffer.visitLines(Buffer.java:149)
        at org.netbeans.lib.terminalemulator.Term.visitLines(Term.java:600)
        at org.netbeans.lib.terminalemulator.Sel.paint(Sel.java:376)
        at org.netbeans.lib.terminalemulator.Term.do_paint(Term.java:1850)
        at org.netbeans.lib.terminalemulator.Screen.paint(Screen.java:89)
Comment 1 Jiri Skrivanek 2001-09-27 09:23:45 UTC
Created attachment 2726 [details]
Stack trace
Comment 2 akemr 2001-09-27 12:34:16 UTC
Ivan, could you look at it please? Its probably in Term.

I can reproduce it the same way as Jiri.
Comment 3 ivan 2001-09-27 22:15:24 UTC
I can't reproduce it.
Can you please specify
- how big is the selection (one word, line, multiple lines etc)
- in what direction you resized.
Comment 4 Jiri Skrivanek 2001-10-01 09:40:31 UTC
I hoped it has been clearly described but once more:

- select ALL lines (including empty ones) in the Output window (whole
area is selected)
- change height of the Output window to be smaller (drag top border of
the window down)
- and see exceptions
Comment 5 akemr 2001-10-01 10:55:59 UTC
This bug appears, when you resize window (e.g. vertically) to be 
smaller than selected area.
Comment 6 ivan 2001-10-02 04:58:58 UTC
Got it.
It happens when you have less text than the window height.
This usually happens with a freshly cleared term into which
only a few lines have been written.
Then if you select everything things go bad.
Comment 7 Lukas Hasik 2001-10-05 11:29:48 UTC
Note: sometimes when OW is resized the selection is lost... And you
have to select it again.
Comment 8 Lukas Hasik 2001-10-11 16:26:06 UTC
I think that the NPE is gone.  This bug could be closed as fixed...

Jiri, could you confirm ?

Comment 9 Jiri Skrivanek 2001-10-11 16:36:35 UTC
Verified in build 20011011-1326.

Probably fixed.
Comment 10 Jiri Skrivanek 2001-10-11 16:37:28 UTC
Verified in build 20011011-1326.
Comment 11 Quality Engineering 2008-12-23 08:26:29 UTC
moving terminal emulator issues to terminalemulator component.
To see the correct version and target milestone of this issue look at Issue
Activity table.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo