Bug 159464 - GSP coloring not preserved when configured
GSP coloring not preserved when configured
Status: RESOLVED FIXED
Product: groovy
Classification: Unclassified
Component: GSP
6.x
All All
: P3 with 1 vote (vote)
: 6.x
Assigned To: Petr Hejl
issues@groovy
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-02 20:50 UTC by Petr Hejl
Modified: 2009-05-25 06:26 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Hejl 2009-03-02 20:50:18 UTC
GSP coloring is not stored so it is valid only in one session. Also investigate a workaround if possible.
Comment 1 syntaxeus 2009-03-24 10:27:25 UTC
Thanks for looking into this. If you could add settings for "Mark Occurrences" it will be great since I am using a dark
theme and the highlighting makes the text unreadable.
Comment 2 syntaxeus 2009-04-21 11:42:46 UTC
Is there any progress at all in this matter?
Comment 3 Petr Hejl 2009-04-23 15:33:45 UTC
Unfortunately I can't reproduce it with daily build. Is this issue still valid?
Comment 4 dmitry_skorikov 2009-04-27 08:04:13 UTC
I can reproduce it in build 200904151401

Steps to reproduce:

1. Install "Extra color themes" plugin
2. In "tools/options/fonts&colors" dialog select "Aloha" theme
3. Select "Grovy server pages (GSP)" from drop-down list
4. Change background color of all list items to "inherited"
5. Press "OK"
6. Restart IDE

7. Open *.GSP file: background color is invalid

8. Open "tools/options/fonts&colors" dialog
9. Select "Grovy server pages (GSP)" from drop-down list
10. Background color is resetted to "[227, 242, 225]"

... and there no way to change "Mark occurences" color in Groovy/GSP files also :(

Comment 5 dmitry_skorikov 2009-04-30 08:36:58 UTC
6.7 Beta - reproduced
Comment 6 Petr Hejl 2009-05-06 16:56:59 UTC
This seems to fixed - web-main 075280960496. Reporter can you verify?

The strange thing is that I've just provide localization. Jirko is this expected? It is quite strange if such thing can
influence whether values are saved/loaded or not.
Comment 7 Jiri Skrivanek 2009-05-07 07:52:25 UTC
Font&Colors panel belongs to editor/options category. If you feel something is wrong, submit a bug in this category.
Comment 8 Quality Engineering 2009-05-07 19:11:56 UTC
Integrated into 'main-golden', will be available in build *200905071401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/075280960496
User: phejl@netbeans.org
Log: #159464 GSP coloring not preserved when configured
Comment 9 Petr Hejl 2009-05-19 15:01:18 UTC
IMO this is fixed now. Please verify.
Comment 10 dmitry_skorikov 2009-05-25 06:26:39 UTC
Color settings is stored now. 
But what about "Mark occurences" setting for Groovy/GSP ?


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo