Bug 159042 - builtin python decorators in code check
builtin python decorators in code check
Status: CLOSED INCOMPLETE
Product: python
Classification: Unclassified
Component: Code
6.x
All Linux
: P3 (vote)
: TBD
Assigned To: Lou Dasaro
nbpythonqa
:
: 160753 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-24 10:14 UTC by robinhood23rus
Modified: 2017-06-23 08:06 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description robinhood23rus 2009-02-24 10:14:31 UTC
In tasks tab warning says "First argument (method) sould be self or cls" But there is a built in decorator
"staticmethod" in method defenition.
Comment 1 Lou Dasaro 2015-01-02 04:44:28 UTC
*** Bug 160753 has been marked as a duplicate of this bug. ***
Comment 2 Jenselme 2017-06-22 22:16:18 UTC
If you still have this issue, please provide a code sample we can test. From my tests, it works as expected.
Comment 3 Jiri Kovalsky 2017-06-23 08:06:28 UTC
Thanks for your evaluation Julien. Reporter, if you think your issue is still valid and needs to be addressed, don't hesitate to reopen it with additional information. Closing for now.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo