Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 158982 - InstanceCreationException: no handlers
InstanceCreationException: no handlers
Status: RESOLVED DUPLICATE of bug 156351
Product: serverplugins
Classification: Unclassified
Component: GlassFish
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Vince Kraemer
issues@serverplugins
: RANDOM
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-23 13:37 UTC by Jaroslav Pospisil
Modified: 2009-02-28 17:43 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
screenshot (125.31 KB, image/png)
2009-02-23 13:39 UTC, Jaroslav Pospisil
Details
messages.log (58.70 KB, text/plain)
2009-02-23 13:40 UTC, Jaroslav Pospisil
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jaroslav Pospisil 2009-02-23 13:37:19 UTC
Build 200902201419,JDK 1.6.0_12, Win Vista SP1

I passed this test specification (http://wiki.netbeans.org/STS_70_Maven). I invoked then Maven Web Application wizard
and during activation of J2EE functionality this exception occured,followed by complete hang up of IDE. I'm attaching
screenshot of frozen IDE and messages.log file.
Comment 1 Jaroslav Pospisil 2009-02-23 13:39:25 UTC
Created attachment 77244 [details]
screenshot
Comment 2 Jaroslav Pospisil 2009-02-23 13:40:15 UTC
Created attachment 77245 [details]
messages.log
Comment 3 Jaroslav Pospisil 2009-02-24 09:43:45 UTC
I've been unable to reproduce issue so far, so adding RANDOM keyword.Probably caused by collision with "Transfer
repository" action.
Comment 4 Milos Kleint 2009-02-27 08:52:40 UTC
there is no maven in the stacktrace. No idea where the code is coming from and what triggers it. Reassigning to
glassfish integration for evaluation.

WARNING [glassfish-javaee]
org.netbeans.modules.j2ee.deployment.plugins.api.InstanceCreationException: no handlers
	at org.netbeans.modules.j2ee.deployment.impl.ServerRegistry.addInstanceImpl(ServerRegistry.java:457)
	at org.netbeans.modules.j2ee.deployment.impl.ServerRegistry.addInstance(ServerRegistry.java:354)
Caused: org.netbeans.modules.j2ee.deployment.plugins.api.InstanceCreationException: Failed to create instance GlassFish
v3 Prelude Domain.  See the server log file for details.
	at org.netbeans.modules.j2ee.deployment.impl.ServerRegistry.addInstance(ServerRegistry.java:356)
	at
org.netbeans.modules.j2ee.deployment.plugins.api.InstanceProperties.createInstancePropertiesWithoutUI(InstanceProperties.java:260)
[catch] at org.netbeans.modules.glassfish.javaee.JavaEEServerModuleFactory.createModule(JavaEEServerModuleFactory.java:112)
	at org.netbeans.modules.glassfish.common.GlassfishInstance.updateModuleSupport(GlassfishInstance.java:157)
	at org.netbeans.modules.glassfish.common.GlassfishInstance.<init>(GlassfishInstance.java:125)
	at org.netbeans.modules.glassfish.common.GlassfishInstance.create(GlassfishInstance.java:196)
	at org.netbeans.modules.glassfish.common.GlassfishInstanceProvider.readInstanceFromFile(GlassfishInstanceProvider.java:368)
	at org.netbeans.modules.glassfish.common.GlassfishInstanceProvider.loadServerInstances(GlassfishInstanceProvider.java:332)
	at org.netbeans.modules.glassfish.common.GlassfishInstanceProvider.<init>(GlassfishInstanceProvider.java:149)
	at org.netbeans.modules.glassfish.common.GlassfishInstanceProvider.getPrelude(GlassfishInstanceProvider.java:100)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:597)
	at org.netbeans.core.startup.layers.BinaryFS$AttrImpl$MethodAndParams.invoke(BinaryFS.java:558)
	at org.netbeans.core.startup.layers.BinaryFS$AttrImpl.getValue(BinaryFS.java:490)
	at org.netbeans.core.startup.layers.BinaryFS$BFSBase.getAttribute(BinaryFS.java:375)
	at org.openide.filesystems.MultiFileObject.getAttribute(MultiFileObject.java:840)
	at org.openide.filesystems.MultiFileObject.getAttribute(MultiFileObject.java:789)
	at org.openide.filesystems.MultiFileObject.getAttribute(MultiFileObject.java:836)
	at org.openide.filesystems.MultiFileObject.getAttribute(MultiFileObject.java:789)
	at org.openide.filesystems.MultiFileObject.getAttribute(MultiFileObject.java:722)
	at org.openide.loaders.InstanceDataObject$Ser.instanceCreate(InstanceDataObject.java:1256)
	at org.openide.loaders.InstanceDataObject.instanceCreate(InstanceDataObject.java:749)
	at org.openide.loaders.FolderLookup$ICItem.getInstance(FolderLookup.java:584)
	at org.openide.util.lookup.AbstractLookup$R.allInstances(AbstractLookup.java:974)
	at org.openide.util.lookup.ProxyLookup$R.computeResult(ProxyLookup.java:548)
	at org.openide.util.lookup.ProxyLookup$R.allInstances(ProxyLookup.java:489)
	at org.openide.util.lookup.ProxyLookup$R.collectFires(ProxyLookup.java:618)
	at org.openide.util.lookup.ProxyLookup$WeakResult.collectFires(ProxyLookup.java:728)
	at org.openide.util.lookup.AbstractLookup.notifyListeners(AbstractLookup.java:541)
	at org.openide.util.lookup.AbstractLookup$R.collectFires(AbstractLookup.java:955)
	at org.openide.util.lookup.AbstractLookup.notifyListeners(AbstractLookup.java:509)
	at org.openide.util.lookup.AbstractLookup$1Notify.run(AbstractLookup.java:308)
	at org.openide.loaders.FolderLookup$Dispatch.run(FolderLookup.java:304)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:573)
	at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:1005)
WARNING [glassfish]: org.netbeans.modules.glassfish.javaee.JavaEEServerModuleFactory@19e5c90 created a null module
Comment 5 Vince Kraemer 2009-02-28 17:43:29 UTC
putting all the case under on issue...

*** This issue has been marked as a duplicate of 156351 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo