Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 158978 - NullPointerException at java.util.ArrayList.<init>
NullPointerException at java.util.ArrayList.<init>
Status: VERIFIED FIXED
Product: debugger
Classification: Unclassified
Component: Java
6.x
All Linux
: P1 (vote)
: 6.x
Assigned To: Martin Entlicher
issues@debugger
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-23 13:32 UTC by Filip Zamboj
Modified: 2009-02-24 20:13 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Filip Zamboj 2009-02-23 13:32:21 UTC
Build: NetBeans IDE Dev (Build 200902201419)
VM: Java HotSpot(TM) 64-Bit Server VM, 11.2-b01, Java(TM) SE Runtime Environment, 1.6.0_12-b04
OS: Linux, 2.6.27-11-generic, amd64
User comments: when trying to uncheck path to jdk sources in sources view. Debugging session was running at the same time. 
STACKTRACE: (first 10 lines)
java.lang.NullPointerException
        at java.util.ArrayList.<init>(ArrayList.java:131)
        at
org.netbeans.modules.debugger.jpda.projects.SourcePathProviderImpl.storeAdditionalSourceRoots(SourcePathProviderImpl.java:406)
        at
org.netbeans.modules.debugger.jpda.projects.SourcePathProviderImpl.setSourceRoots(SourcePathProviderImpl.java:742)
        at org.netbeans.modules.debugger.jpda.ui.SourcePath.setSourceRoots(SourcePath.java:176)
        at org.netbeans.modules.debugger.jpda.ui.models.SourcesModel.setEnabled(SourcesModel.java:286)
        at org.netbeans.modules.debugger.jpda.ui.models.SourcesModel.setValueAt(SourcesModel.java:230)
        at org.netbeans.spi.viewmodel.Models$DelegatingTableModel.setValueAt(Models.java:1595)
        at org.netbeans.spi.viewmodel.Models$CompoundModel.setValueAt(Models.java:3141)
        at org.netbeans.modules.viewmodel.TreeModelNode$MyProperty$1.run(TreeModelNode.java:1121)
        at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:573)
Comment 1 Filip Zamboj 2009-02-23 13:35:36 UTC
I'm just wondering if there is any workaround for this .. if no then this is P1, eventually. 

i already tried to run with a clean userdir, tried to find another way how to uncheck sources. 
Comment 2 Filip Zamboj 2009-02-23 13:54:22 UTC
issue was reproduced on MS Vista, jdk 1.6.0_12-b04, build Build 200902201419
Comment 3 Martin Entlicher 2009-02-23 13:58:08 UTC
Workaround is to setup sources before the debugger session is running.
Comment 4 Martin Entlicher 2009-02-23 13:59:21 UTC
Reproduced, working on a fix...
Comment 5 Filip Zamboj 2009-02-23 15:08:42 UTC
priority to P2 so this could be committed to 67M2 if fix will be ready
Comment 6 Martin Entlicher 2009-02-23 15:43:47 UTC
While fixing this, I've found several other issues:

- Sources view gets empty when the window is opened, then debugging session is started, several windows are switched,
debugging session is finished and Sources tab is viewed again.

- For projects with compile-on-save turned on the sources unselected in "static" Sources window are not ported to
session-specific Sources window.

All problems are easy-to-fix.
Comment 8 Filip Zamboj 2009-02-23 16:08:32 UTC
cause of more issues found there is a reason to higher to P1. This allow us to commit changes into 67M2. 

Thanks Martin!  
Comment 9 Filip Zamboj 2009-02-23 16:08:44 UTC
cause of more issues found there is a reason to higher to P1. This allow us to commit changes into 67M2. 

Thanks Martin!  
Comment 10 Marian Mirilovic 2009-02-23 16:13:15 UTC
go ahead with integration, then we'll run another build from m2 clone
Comment 12 Filip Zamboj 2009-02-24 12:46:14 UTC
seems to be fine
Comment 13 Quality Engineering 2009-02-24 20:13:20 UTC
Integrated into 'main-golden', will be available in build *200902241401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/a808d0ee6e47
User: mentlicher@netbeans.org
Log: #158978 - Prevent from NPE when additionalSourceRoots == null.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo