Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 158960 - "Add Server" does not open dialog, raises NullPointerException
"Add Server" does not open dialog, raises NullPointerException
Status: RESOLVED DUPLICATE of bug 150223
Product: ide
Classification: Unclassified
Component: UI
6.x
Other Linux
: P2 (vote)
: 6.x
Assigned To: issues@ide
issues@ide
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-23 03:06 UTC by mishom
Modified: 2009-02-25 13:40 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mishom 2009-02-23 03:06:19 UTC
Platform: 

NetBeans 6.5
Slackware Linux 12.2 (32bit)
Sun JDK 1.6.0_12 

Problem: 

Go to tab "Services", right-click on "Servers" and try "Add Server". No dialog appears and you got a Stop sign at the
bottom right corner. Click on it and it shows stack trace for a NullPointerException.
However, Adding Server seems broken only when the JDK is the latest 1.6.0_12, and it works fine if I revert to previous
build 1.6.0_11. It seems that JDK 1.6.0 Update 12 does not play well with NetBeans 6.5. Again, this does not happen with
JDK 1.6.0 Update 7 and 11, which I tested. Those work fine. 
Below is the stack trace.

Thanks,
Mihail Merdjanov


java.lang.NullPointerException
	at org.netbeans.modules.server.ui.wizard.ServerWizardVisual.isServerValid(ServerWizardVisual.java:155)
	at org.netbeans.modules.server.ui.wizard.ServerWizardVisual.isValid(ServerWizardVisual.java:146)
	at java.awt.Component.invalidateIfValid(Component.java:2740)
	at java.awt.Component.setLocale(Component.java:1810)
	at javax.swing.JComponent.<init>(JComponent.java:595)
	at javax.swing.JPanel.<init>(JPanel.java:65)
	at javax.swing.JPanel.<init>(JPanel.java:92)
	at javax.swing.JPanel.<init>(JPanel.java:100)
	at org.netbeans.modules.server.ui.wizard.ServerWizardVisual.<init>(ServerWizardVisual.java:83)
	at org.netbeans.modules.server.ui.wizard.ServerWizardPanel.getComponent(ServerWizardPanel.java:68)
	at
org.netbeans.modules.server.ui.wizard.AddServerInstanceWizard$AddServerInstanceWizardIterator.initialize(AddServerInstanceWizard.java:295)
	at org.openide.WizardDescriptor.callInitialize(WizardDescriptor.java:1417)
	at org.openide.WizardDescriptor.<init>(WizardDescriptor.java:472)
	at org.openide.WizardDescriptor.<init>(WizardDescriptor.java:481)
	at org.netbeans.modules.server.ui.wizard.AddServerInstanceWizard.<init>(AddServerInstanceWizard.java:107)
	at org.netbeans.modules.server.ui.wizard.AddServerInstanceWizard.<init>(AddServerInstanceWizard.java:94)
	at
org.netbeans.modules.server.ui.wizard.AddServerInstanceWizard.showAddServerInstanceWizard(AddServerInstanceWizard.java:134)
	at org.netbeans.modules.server.ui.node.AddServerInstanceAction.performAction(AddServerInstanceAction.java:58)
	at org.openide.util.actions.NodeAction$DelegateAction$1.run(NodeAction.java:581)
	at org.netbeans.modules.openide.util.ActionsBridge.doPerformAction(ActionsBridge.java:77)
	at org.openide.util.actions.NodeAction$DelegateAction.actionPerformed(NodeAction.java:577)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1995)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2318)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:387)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:242)
	at javax.swing.AbstractButton.doClick(AbstractButton.java:357)
	at javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:1225)
	at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(BasicMenuItemUI.java:1266)
	at java.awt.Component.processMouseEvent(Component.java:6216)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3265)
	at java.awt.Component.processEvent(Component.java:5981)
	at java.awt.Container.processEvent(Container.java:2041)
	at java.awt.Component.dispatchEventImpl(Component.java:4583)
	at java.awt.Container.dispatchEventImpl(Container.java:2099)
	at java.awt.Component.dispatchEvent(Component.java:4413)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4556)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4220)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4150)
	at java.awt.Container.dispatchEventImpl(Container.java:2085)
	at java.awt.Window.dispatchEventImpl(Window.java:2475)
	at java.awt.Component.dispatchEvent(Component.java:4413)
[catch] at java.awt.EventQueue.dispatchEvent(EventQueue.java:599)
	at org.netbeans.core.TimableEventQueue.dispatchEvent(TimableEventQueue.java:104)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)
Comment 1 mishom 2009-02-23 17:21:14 UTC
I checked with my other PC, running Windows XP Pro, NetBeans 6.5 and JDK 1.6.0_12. It happens there too, and if I 
revert my JDK to the previous one - 1.6.0 Update 11, then it works fine.
So, apparently this problem is not OS dependent, just JDK dependent.
Comment 2 Jindrich Sedek 2009-02-25 13:40:52 UTC
patch will be provided in two weeks.

Thanks for reporting the problem

*** This issue has been marked as a duplicate of 150223 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo