Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 158798 - IDE Freezed when entering step filter through options
IDE Freezed when entering step filter through options
Status: CLOSED INVALID
Product: debugger
Classification: Unclassified
Component: Code
6.x
All Linux
: P3 (vote)
: TBD
Assigned To: issues@debugger
issues@debugger
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-19 10:43 UTC by Filip Zamboj
Modified: 2010-04-29 09:48 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Messages.log (53.30 KB, text/plain)
2009-02-19 10:44 UTC, Filip Zamboj
Details
Frozen IDE (140.49 KB, image/png)
2009-02-19 10:45 UTC, Filip Zamboj
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Filip Zamboj 2009-02-19 10:43:04 UTC
I entered EMPTY step filter in new Java Debugger Options found in tools->options->miscellaneous->Java Debugger. At this
point my IDE freezed. 

Log and picture attached.
Comment 1 Filip Zamboj 2009-02-19 10:44:48 UTC
Created attachment 77140 [details]
Messages.log
Comment 2 Filip Zamboj 2009-02-19 10:45:37 UTC
Created attachment 77141 [details]
Frozen IDE
Comment 3 Filip Zamboj 2009-02-19 10:53:55 UTC
Product Version: NetBeans IDE Dev (Build 200902180201)
Java: 1.6.0_12-ea; Java HotSpot(TM) 64-Bit Server VM 11.2-b01
System: Linux version 2.6.27-11-generic running on amd64; UTF-8; en_US (nb)
Userdir: /home/felipee/SUN/userdirs/dev_0201

OS: ubuntu 8.10 
Comment 4 Martin Entlicher 2009-02-19 13:26:43 UTC
Can you please provide a complete thread dump? When IDE freezes, message.log does not contain any interesting
information, full thread dump is necessary.
Comment 5 Martin Entlicher 2009-02-19 14:29:27 UTC
Please note, that on JDK 6u12 I get freezes of AWT very often. This is an AWT issue:
"AWT-XAWT":
        at sun.awt.X11.XWindow.setMouseAbove(XWindow.java:793)
        - waiting to lock <0x9035b028> (a sun.awt.X11.XDialogPeer)
        at sun.awt.X11.XWindowPeer.setMouseAbove(XWindowPeer.java:1009)
        at sun.awt.X11.XWindow.leaveNotify(XWindow.java:803)
        at sun.awt.X11.XWindow.handleXCrossingEvent(XWindow.java:816)
        at sun.awt.X11.XWindowPeer.handleXCrossingEvent(XWindowPeer.java:1729)
        at sun.awt.X11.XBaseWindow.dispatchEvent(XBaseWindow.java:1119)
        at sun.awt.X11.XBaseWindow.dispatchToWindow(XBaseWindow.java:1079)
        at sun.awt.X11.XToolkit.dispatchEvent(XToolkit.java:475)
        at sun.awt.X11.XToolkit.run(XToolkit.java:588)
        at sun.awt.X11.XToolkit.run(XToolkit.java:523)
        at java.lang.Thread.run(Thread.java:619)

Found 1 deadlock.

This is already submitted at http://bugs.sun.com/view_bug.do?bug_id=6786210.

So please, provide the thread dump so that we can close this if it's the case.
Comment 6 Marian Mirilovic 2009-02-19 17:13:49 UTC
Martin, mentioned issue is fixed in JDk6u12 ... so ?
Comment 7 Filip Zamboj 2009-02-19 17:27:33 UTC
Well, Martin is probably right that this an issue in AWT. This is not first time IDE got frozen and it didn't happened
to me so many times before. Therefore I'm lowering priority to P3 and don't consider this as debugger stopper for 6.7M2.
I'll provide thread dump asap (today/tomorrow). What's more I found out it doesn't freeze every time.  
Comment 8 Martin Entlicher 2009-02-19 17:41:09 UTC
The bug is fixed in  6u12(b04). Zamboj, do you have b04?
Anyway, we can not talk about this unless we see the thread dump. JDK bug 6786210 was just my speculation, because I hit
that often on JDK 6u12 b03.
Comment 9 Filip Zamboj 2009-02-25 18:25:46 UTC
didn't reproduce since jdk6u12b04 installed. Can you close this issue (as I don't see this option here)? I'll reopen in
case I encounter this again. 

Thanks. 
Filip. 
Comment 10 Filip Zamboj 2009-03-12 19:46:45 UTC
not reproducible on jdk6u12b0x where x>3
Comment 11 Quality Engineering 2010-04-29 09:48:10 UTC
Verified ... and Closing all issues resolved into NetBeans 6.7 and earlier.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo