Bug 15870 - database explorer -- postgresql jdbc driver causes exception on startup
database explorer -- postgresql jdbc driver causes exception on startup
Status: CLOSED WORKSFORME
Product: db
Classification: Unclassified
Component: Code
3.x
PC Linux
: P3 (vote)
: TBD
Assigned To: Radko Najman
issues@db
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-24 19:17 UTC by Matthew Kennedy
Modified: 2003-06-30 17:17 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
ide.log detailing the unexpected exception (38.29 KB, text/plain)
2001-09-24 19:19 UTC, Matthew Kennedy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matthew Kennedy 2001-09-24 19:17:48 UTC
I remove nbuser32/ and my netbeans install
install netbeans 3.2.1 fomr scratch
start netbeans, setup using defaults
goto update center
update all packages (include db -- database explorer)
netbeans restarts as usual
goto runtime panel, database explorer,
click on drivers node, i get a list of driver templates etc.

^^^ all of the above is normal.

Then I proceed to install the postgresql jdbc jar
I quit netbeans
cd ~/lib/netbeans/lib/ext
ln -s /usr/share/pgsql/jdbc7.1-1.2.jar jdbc7.1-1.2.jar
then restart netbeans...

then I get the exception (attached)


I am using:

$ rpm -q redhat-release jdk postgresql postgresql-jdbc
redhat-release-7.1-1
jdk-1.3.1-fcs
postgresql-7.1.2-5PGDG
postgresql-jdbc-7.1.2-5PGDG
Comment 1 Matthew Kennedy 2001-09-24 19:19:09 UTC
Created attachment 2678 [details]
ide.log detailing the unexpected exception
Comment 2 Radko Najman 2001-09-25 10:31:33 UTC
I think the problem is that your are using a link to the JDBC driver 
jar insteand of the real driver jar and the security manager doesn't 
allow you to load the classes from the linked jar. Copy the driver to 
the lib/ext directory and it should work.
Comment 3 Radko Najman 2001-10-02 11:34:51 UTC
Closing as WORKSFORME. (for more info see the previous comment)
Comment 4 Martin Schovanek 2003-03-12 13:53:59 UTC
VERIFIED
Comment 5 Quality Engineering 2003-06-30 17:17:42 UTC
Resolved for 3.3.x or earlier, no new info since then -> closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo