Bug 158681 - Extend VCS spi with getAtribute
Extend VCS spi with getAtribute
Status: RESOLVED FIXED
Product: versioncontrol
Classification: Unclassified
Component: Code
5.x
Macintosh All
: P1 (vote)
: TBD
Assigned To: issues@versioncontrol
issues@versioncontrol
: API_REVIEW_FAST
: 158600 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-17 15:27 UTC by Tomas Stupka
Modified: 2009-05-20 07:25 UTC (History)
0 users

See Also:
Issue Type: TASK
:


Attachments
changes in master fs (3.79 KB, patch)
2009-02-17 16:01 UTC, Tomas Stupka
Details | Diff
changes in vcs (7.25 KB, patch)
2009-02-17 16:04 UTC, Tomas Stupka
Details | Diff
changes in vcs (2.67 KB, text/plain)
2009-05-12 12:21 UTC, Tomas Stupka
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Stupka 2009-02-17 15:27:58 UTC
Due to the integration with kenai involved VCS systems (svn hg) have to provide the remote location for a versioned file.

The new method getAttribute(File file, String attrName) in the VCSInterceptor should provide additional VCS specific
information about versioned files. 

The only supported attribute at this moment is VCSInterceptor.ATTRIBUTE_REMOTE_LOCATION =
"ProvidedExtensions.RemoteLocation" for which VCS systems overrinding getAttribute should return the files remote
repository, resp. remote origin. (e.g. Repository URL in case of SVN or default pull in case of Mercurial).
Comment 1 Tomas Stupka 2009-02-17 16:01:55 UTC
Created attachment 77080 [details]
changes in master fs
Comment 2 Tomas Stupka 2009-02-17 16:04:23 UTC
Created attachment 77081 [details]
changes in vcs
Comment 3 Tomas Stupka 2009-02-17 16:05:31 UTC
*** Issue 158600 has been marked as a duplicate of this issue. ***
Comment 4 Tomas Stupka 2009-05-12 12:19:47 UTC
getAttribute(File file, String attrName) in the VCSInterceptor returns a String while the MasterFs getAttribute(final
File file, final String attrName) method it delegates to returns an Object. As there is no reason for such a limitation
in the VCSInterceptor and there is already a request for a new friend attribute returning Runnable (see below) we should
change the return value to Object. Please note that the getAttribute() api wasn't released yet. 

changes:
========

- VCSInterceptor.getAttribute should return Object instead of String
- new friend attribute "ProvidedExtensions.Refresh" which returns a runnable to refresh the VCS Status for the file
given in getAttribute 


Comment 5 Tomas Stupka 2009-05-12 12:21:00 UTC
Created attachment 81950 [details]
changes in vcs
Comment 6 Tomas Stupka 2009-05-19 13:11:56 UTC
changeset:   132062:ea09c007b94b
user:        Tomas Stupka <tstupka@netbeans.org>
date:        Tue May 19 12:00:57 2009 +0200
Comment 7 Quality Engineering 2009-05-20 07:25:03 UTC
Integrated into 'main-golden', will be available in build *200905200201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/ea09c007b94b
User: Tomas Stupka <tstupka@netbeans.org>
Log: #158681 - Extend VCS spi with getAtribute


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo