Bug 158621 - Watch query "Show only rows where" has no possibility to show all items if no result of query
Watch query "Show only rows where" has no possibility to show all items if no...
Status: RESOLVED DUPLICATE of bug 157306
Product: platform
Classification: Unclassified
Component: Outline&TreeTable
6.x
All Linux
: P3 (vote)
: 6.x
Assigned To: Jiri Rechtacek
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-16 15:57 UTC by Filip Zamboj
Modified: 2009-04-07 15:17 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Filip Zamboj 2009-02-16 15:57:26 UTC
If you insert more variables to watch int watch view and you use "Show only rows where ... " action that has no result
you can't get it back in the same view. You have to switch to another view and back ... but that means this view is not
persistent. 


Wouldn't it be better to 
1. add possibility to show all items in watches in view if none returned by 'query'?  
2. make it persistent?
Comment 1 Martin Entlicher 2009-02-24 10:34:49 UTC
The action is defined in openide.explorer.

I do not think we should make it persistent. You can easily forget that you've filtered the rows and later wonder why
you do not see some variables.
Comment 2 Stanislav Aubrecht 2009-04-07 15:17:25 UTC

*** This issue has been marked as a duplicate of 157306 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo