Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 158617 - IllegalArgumentException: D:\projects\subversion\www\com\mysubversion\NewSubversionFile.java is not inside D:\projects\subversion\www
IllegalArgumentException: D:\projects\subversion\www\com\mysubversion\NewSubv...
Status: RESOLVED DUPLICATE of bug 157361
Product: projects
Classification: Unclassified
Component: Ant Project
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Milan Kubec
issues@projects
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
: RANDOM
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-16 15:22 UTC by adam_myatt
Modified: 2009-05-13 12:50 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.04 KB, text/plain)
2009-02-16 15:23 UTC, adam_myatt
Details

Note You need to log in before you can comment on or make changes to this bug.
Description adam_myatt 2009-02-16 15:22:58 UTC
Build: NetBeans IDE 6.5 (Build 200811100001)
VM: Java HotSpot(TM) Client VM, 1.6.0_02-b05, Java(TM) SE Runtime Environment, 1.6.0_02-b05
OS: Windows XP, 5.1, x86

User Comments:
adam_myatt: had an open javase project, clicked to delete it and delete source as well. delete took place but after project disappeared from listing in projects window the error occurred, though delete seemed to function as normal.



Stacktrace: 
java.lang.IllegalArgumentException: D:\projects\subversion\www\com\mysubversion\NewSubversionFile.java is not inside D:\projects\subversion\www
        at org.netbeans.spi.project.support.ant.SourcesHelper$SourceRoot$Group.contains(SourcesHelper.java:180)
        at org.netbeans.spi.java.project.support.ui.PackageViewChildren$NoFoldersDataFilter.acceptFileObject(PackageViewChildren.java:1160)
        at org.openide.loaders.FolderChildren$1R.run(FolderChildren.java:157)
        at org.openide.util.Mutex$1Exec.run(Mutex.java:1239)
        at org.openide.nodes.Children$ProjectManagerDeadlockDetector.execute(Children.java:1796)
        at org.openide.util.Mutex.postRequest(Mutex.java:1245)
Comment 1 adam_myatt 2009-02-16 15:23:15 UTC
Created attachment 77025 [details]
stacktrace
Comment 2 Milan Kubec 2009-05-13 12:50:29 UTC

*** This issue has been marked as a duplicate of 157361 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo