Bug 158526 - Fields Attributes not managed, autocompetion error
Fields Attributes not managed, autocompetion error
Status: CLOSED FIXED
Product: python
Classification: Unclassified
Component: Editor
8.1
All All
: P3 (vote)
: 8.1
Assigned To: ardavis26
nbpythonqa
:
: 158524 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-13 14:02 UTC by zorg724
Modified: 2017-06-23 08:06 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description zorg724 2009-02-13 14:02:56 UTC
Hello,
Python editor Error:
I continue to use Pyscripter editor, because Netbeen is not ready to replace it.
For exemple, it is not possible to display class instance attribute:
ex:
class A :
   def __init__(self):
       self.attribut

   def a_method (self):
       self.-----> Autocompletion ERROR : netbeen does not display attribute instance. And it display a lot of thing
  that is impossible .

Zorg.
Comment 1 Lou Dasaro 2015-05-19 04:57:04 UTC
AFAIK, this has been partially fixed: now lists "no suggestions", which is still not right, but better than a bunch of nonsensical suggestions.
Comment 2 Lou Dasaro 2015-05-19 05:47:25 UTC
*** Bug 158524 has been marked as a duplicate of this bug. ***
Comment 3 Jenselme 2017-06-22 21:30:53 UTC
Completion is being reworked for the new release planed in August. Not sure it is still relevant with the current version. Closing this as old bug.
Comment 4 Jiri Kovalsky 2017-06-23 08:06:28 UTC
Thanks for your evaluation Julien. Reporter, if you think your issue is still valid and needs to be addressed, don't hesitate to reopen it with additional information. Closing for now.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo