Bug 15847 - Output Window swallows global keystrokes
Output Window swallows global keystrokes
Status: CLOSED FIXED
Product: cnd
Classification: Unclassified
Component: Terminalemulator
3.x
PC Linux
: P4 (vote)
: 6.x
Assigned To: akemr
ivan
: A11Y
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-24 12:02 UTC by Jesse Glick
Modified: 2008-12-23 08:42 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2001-09-24 12:02:03 UTC
[dev sep 23] I'm sure this is known about, but after giving focus to
the Output Window, all other IDE keyboard shortcuts (e.g. Ctrl-2) fail
to work until the mouse is clicked elsewhere. This is terrible for
accessibility and keyboard navigability. If global keyboard shortcuts
cannot be kept enabled when the Output Window (term) is focussed, I
would prefer if the OW were _never_ automatically given keyboard
focus, i.e. you would have to click on it in order to give it focus.
Otherwise it is very unpleasant for keyboard users to ever compile
etc.
Comment 1 akemr 2001-09-24 13:26:33 UTC
Fixed in main trunk. It was my fault, IDE shortcuts should work
correctly now..
Comment 2 Jesse Glick 2001-09-25 11:29:02 UTC
Ctrl-2 does indeed work in [dev sep 24], thank you... not quite
resolved I think because posting menus with the OW selected does not
work. E.g. Alt-F does not open the File menu. Of course you can jump
to some other window such as the Explorer first, so this is not nearly
as important as that it is possible to "escape" using the KB. Making
P4, maybe P5 would be OK.
Comment 3 akemr 2001-09-25 13:17:53 UTC
Fixed in trunk.
Comment 4 Jesse Glick 2001-09-26 13:50:07 UTC
It looks fine for me using [dev sep 25 evening]--thanks!
Comment 5 Jan Chalupa 2001-10-10 16:07:27 UTC
Adding 'A11Y' keyword.
Comment 6 rmatous 2001-11-21 15:58:32 UTC
*** Issue 9676 has been marked as a duplicate of this issue. ***
Comment 7 Quality Engineering 2003-07-01 16:43:30 UTC
Resolved for 3.4.x or earlier, no new info since then -> closing.
Comment 8 Quality Engineering 2008-12-23 08:42:18 UTC
moving terminal emulator issues to terminalemulator component.
To see the correct version and target milestone of this issue look at Issue
Activity table.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo