Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 158194 - Eliminate a lot of SourceForBinaryQueries
Eliminate a lot of SourceForBinaryQueries
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: Classpath
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Pavel Flaska
issues@java
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-09 12:49 UTC by Jaroslav Tulach
Modified: 2009-05-18 08:45 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jaroslav Tulach 2009-02-09 12:49:08 UTC
Rumor has it that there is too much queries to SourceForBinaryQuery class during opening of project, computing its 
classpath transitive closure and parsing it. Please measure how much time/disk access can be eliminated by caching 
queries for the same JARs/folders and implement an intelligent cache that will invalidate itself when query result 
changes.
Comment 1 Pavel Flaska 2009-02-20 10:56:10 UTC
The rumors did not mention, that the problem is perhaps only related API support projects. I tried it with several
simple J2SE projects and was unable to reproduce it on J2SE. But - just to be sure - we need to setup more project with
complex dependencies to ensure that J2SE is not affected.

We discussed possible solution with Jarda and agreed that I will try to transform several API support modules with their
dependencies to J2SE projects.
Comment 2 Pavel Flaska 2009-04-30 21:38:59 UTC
We agreed we will test it in maven projects too.
Comment 3 Pavel Flaska 2009-05-18 08:45:57 UTC
Fix of #162706 improved behavior for projects with many dependencies. 


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo