Bug 158192 - Empty "Attach" and "New Breakpoint" dialog on JDK 6u12
Empty "Attach" and "New Breakpoint" dialog on JDK 6u12
Status: VERIFIED FIXED
Product: debugger
Classification: Unclassified
Component: Code
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Martin Entlicher
issues@debugger
65fixes3-verified
: JDK_SPECIFIC, RELNOTE
: 158243 160166 (view as bug list)
Depends on:
Blocks: 154624
  Show dependency treegraph
 
Reported: 2009-02-09 12:39 UTC by Jaromir Uhrik
Modified: 2009-04-16 19:23 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Screenshot attached... (59.67 KB, image/png)
2009-02-09 12:41 UTC, Jaromir Uhrik
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jaromir Uhrik 2009-02-09 12:39:55 UTC
Product Version: NetBeans IDE Dev (Build 200902090201)
Java: 1.6.0_13-ea; Java HotSpot(TM) Server VM 11.3-b01
System: Windows XP version 5.1 running on x86; Cp1252; en_US (nb)

Steps to reproduce:
-create new java se project 
-in Main class put the cursor to the line with the main method definition
-from main menu select Debug>New Breakpoint...
-->> The dialog that appears has only Brekpoint Type combo box visible. Other components are not visible on my Win XP.
On Mac OS X it is fine. See attached screenshot with both Win/Mac dialog look...
Comment 1 Jaromir Uhrik 2009-02-09 12:41:05 UTC
Created attachment 76737 [details]
Screenshot attached...
Comment 2 Jaromir Uhrik 2009-02-09 13:24:33 UTC
Changing the priority to P1 because adding breakpoint is not possible on windows.
Comment 3 Daniel Prusa 2009-02-09 15:11:29 UTC
This is not reproducible for me with basic ide build, the problem could be related to some other debugger modules. I
will look at it.
Comment 4 Martin Entlicher 2009-02-09 19:27:37 UTC
Happens since JDK 6u12 on all platforms.
It's a severe regression of debugger UI. The cause is the same as in issue #157300 and can be fixed in the same way - by
not overriding isValid() method of UI components.

Due to a clash of isValid() method with Controller interface, the fix is not so simple as in issue #157300.

Nearly all debuggers are affected - JPDA, BPEL, CND, PHP, Ruby, JSP and Javascript.
Comment 5 Martin Entlicher 2009-02-10 07:05:07 UTC
*** Issue 158243 has been marked as a duplicate of this issue. ***
Comment 6 jessholle 2009-02-10 12:15:05 UTC
This is marked as target milestone 7.0M2?!?

This must be fixed as soon as possible in 6.5, not just 7.0 as this is causing great developer frustration in 6.5.
Comment 7 Martin Entlicher 2009-02-10 14:20:16 UTC
This is a defect.
Comment 8 Martin Entlicher 2009-02-10 14:22:24 UTC
jessholle, target milestone is 7.0M2, because we're fixing every issue in current trunk first.
After the fix is done and properly tested, it can be decided to backport it to an older release.
Comment 9 Martin Entlicher 2009-02-10 15:01:56 UTC
Fixed in changeset:   116827:0d1978f24dd0
http://hg.netbeans.org/main/rev/9a20c1c87e2b

Please test if all components are displayed right and work correctly. All panels in Attach and New Breakpoint dialog
were changed.
Comment 10 jessholle 2009-02-10 21:18:16 UTC
I've also noticed lately that my breakpoints don't show up in the breakpoints window -- even after re-installing
NetBeans 6.5.

I've moved back to Java 6 Update 11 from Update 12, so the Attach Debugger dialog works again, but I'm wondering if
there's not a related bug with the breakpoints window that also exists with Update 11.

Is the breakpoints window issue a known issue?
Comment 11 Jaromir Uhrik 2009-02-11 08:08:41 UTC
jessholle, there is issue #157300 related to "missing breakpoints checkboxes" in breakpoints window. But breakpoint
nodes are there as I know and also this issue is available since JDK6 Update12.
Comment 12 Marian Mirilovic 2009-02-11 11:55:43 UTC
*** Issue 158058 has been marked as a duplicate of this issue. ***
Comment 13 Quality Engineering 2009-02-18 10:34:54 UTC
Integrated into 'main-golden', will be available in build *200902180201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/9a20c1c87e2b
User: mentlicher@netbeans.org
Log: #158192 - Components for Attach panel must not implement Controller interface, due to a clash of isValid() method. All attach panels are rewritten to provide a separate implementation of Controller interface. Breakpoint panels also should not implement the Controller interface. But as a simple fix, we do not call isValid() method for controllers that extends JComponent. Therefore not overriding isValid() is enough if panels should be always valid.
Comment 14 Filip Zamboj 2009-02-19 11:56:16 UTC
verified on Build 200902180201
Comment 15 Martin Entlicher 2009-02-26 17:30:09 UTC
The fix is ported into release65_fixes:

http://hg.netbeans.org/release65_fixes/rev/a2d515ea5cc3
http://hg.netbeans.org/release65_fixes/rev/01732171173f
Comment 16 Filip Zamboj 2009-02-27 11:23:49 UTC
verified
Product Version: NetBeans IDE 6.5.1 (Build 200902270001)
Comment 17 Martin Schovanek 2009-03-18 17:09:07 UTC
*** Issue 160166 has been marked as a duplicate of this issue. ***
Comment 18 Quality Engineering 2009-04-16 19:23:13 UTC
Integrated into 'main-golden', will be available in build *200904161401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/a3c60391545d
User: Pavel Flaska <pflaska@netbeans.org>
Log: #161862: Customizer has to be obtained before customizer. Reflect changes in #158192.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo