Bug 158161 - NullPointerException at org.netbeans.modules.mobility.project.ui.customizer.AddAttributePanel.getKey
NullPointerException at org.netbeans.modules.mobility.project.ui.customizer.A...
Status: VERIFIED FIXED
Product: javame
Classification: Unclassified
Component: Build System
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Petr Suchomel
issues@mobility
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT, 65fixes3-verified
:
: 158727 (view as bug list)
Depends on: 154624
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-08 23:32 UTC by kronenthaler
Modified: 2009-03-16 16:32 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (6.45 KB, text/plain)
2009-02-08 23:32 UTC, kronenthaler
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kronenthaler 2009-02-08 23:32:01 UTC
Build: NetBeans IDE 6.5 (Build 200811100001)
VM: Java HotSpot(TM) 64-Bit Server VM, 11.2-b01, Java(TM) SE Runtime Environment, 1.6.0_12-b04
OS: Linux, 2.6.27-11-generic, amd64

User Comments:
kronenthaler: Trying to add or edit a new midlet.

kronenthaler: Trying to add or edit a new midlet.



Stacktrace: 
java.lang.NullPointerException
        at org.netbeans.modules.mobility.project.ui.customizer.AddAttributePanel.getKey(AddAttributePanel.java:135)
        at org.netbeans.modules.mobility.project.ui.customizer.AddAttributePanel.isValid(AddAttributePanel.java:154)
        at java.awt.Component.invalidateIfValid(Component.java:2740)
        at java.awt.Component.setLocale(Component.java:1810)
        at javax.swing.JComponent.<init>(JComponent.java:595)
        at javax.swing.JPanel.<init>(JPanel.java:65)
Comment 1 kronenthaler 2009-02-08 23:32:06 UTC
Created attachment 76718 [details]
stacktrace
Comment 2 Petr Suchomel 2009-02-16 10:27:52 UTC
Fixed in trunk
Comment 3 Andrei Chistiakov 2009-02-17 13:28:39 UTC
Verified with  NetBeans IDE Dev (Build 200902161401).
Comment 4 Marian Mirilovic 2009-02-18 12:01:29 UTC
*** Issue 158727 has been marked as a duplicate of this issue. ***
Comment 5 Marian Mirilovic 2009-03-03 14:33:19 UTC
http://hg.netbeans.org/release65_fixes/rev/5e58d42be709
Comment 6 Andrei Chistiakov 2009-03-05 16:30:51 UTC
Verified with NetBeans IDE 6.5.1 (Build 200903050001)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo