Bug 158094 - OutOfMemoryError: Java heap space
OutOfMemoryError: Java heap space
Status: RESOLVED INCOMPLETE
Product: db
Classification: Unclassified
Component: Code
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Jiri Rechtacek
issues@db
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-06 16:50 UTC by diegohp
Modified: 2009-10-07 10:54 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (2.19 KB, text/plain)
2009-02-06 16:50 UTC, diegohp
Details

Note You need to log in before you can comment on or make changes to this bug.
Description diegohp 2009-02-06 16:50:15 UTC
Build: NetBeans IDE 6.5 (Build 200811100001)
VM: Java HotSpot(TM) Client VM, 11.0-b16, Java(TM) SE Runtime Environment, 1.6.0_11-b03
OS: Windows 2003, 5.2, x86

User Comments:
diegohp: Doing a SELECT in a MySQL table that doesn't have records.

GUEST: opening the update manager

GUEST: Out of memory while executing sql queries with MySQL

GUEST: RUNING AN SQL QUERRY

diegohp: Doing a SELECT in a MySQL table that doesn't have records.



Stacktrace: 
java.lang.OutOfMemoryError: Java heap space
        at com.sun.org.apache.xerces.internal.dom.DeferredDocumentImpl.createChunk(DeferredDocumentImpl.java:1921)
        at com.sun.org.apache.xerces.internal.dom.DeferredDocumentImpl.ensureCapacity(DeferredDocumentImpl.java:1826)
        at com.sun.org.apache.xerces.internal.dom.DeferredDocumentImpl.createNode(DeferredDocumentImpl.java:1840)
        at com.sun.org.apache.xerces.internal.dom.DeferredDocumentImpl.createDeferredTextNode(DeferredDocumentImpl.java:534)
        at com.sun.org.apache.xerces.internal.parsers.AbstractDOMParser.characters(AbstractDOMParser.java:1189)
        at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(XMLDocumentFragmentScannerImpl.java:463)
Comment 1 diegohp 2009-02-06 16:50:20 UTC
Created attachment 76673 [details]
stacktrace
Comment 2 Exceptions Reporter 2009-02-06 17:01:19 UTC
This issue has already 10 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=43034
Comment 3 Jiri Rechtacek 2009-02-10 15:39:17 UTC
Reassigned to new owner.
Comment 4 Jiri Rechtacek 2009-02-24 16:00:21 UTC
Much memory consuming by DOM parser.
Comment 5 Jiri Rechtacek 2009-09-03 15:12:09 UTC
please, provide more details about the issue. We need to know how to reproduce it.
Could you take thread dump when editor uses all memory? - http://wiki.netbeans.org/GenerateThreadDump
Also you can since NetBeans6.7 invoke the button "Profile Me" from IDE's toolbar and attach the results. Thanks
Comment 6 Exceptions Reporter 2009-09-09 21:56:43 UTC
This issue already has 21 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=43034


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo