Bug 157965 - NullPointerException at org.netbeans.modules.j2ee.sun.ide.sunresources.wizards.CommonAttributePanel.isValid
NullPointerException at org.netbeans.modules.j2ee.sun.ide.sunresources.wizard...
Status: VERIFIED FIXED
Product: serverplugins
Classification: Unclassified
Component: Sun Appserver 8
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Nitya Doraisamy
issues@serverplugins
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT, 65fixes3-fixed
:
: 158349 159070 (view as bug list)
Depends on:
Blocks: 154624
  Show dependency treegraph
 
Reported: 2009-02-05 06:48 UTC by nagabalaji
Modified: 2009-10-04 03:41 UTC (History)
7 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (7.32 KB, text/plain)
2009-02-05 06:48 UTC, nagabalaji
Details

Note You need to log in before you can comment on or make changes to this bug.
Description nagabalaji 2009-02-05 06:48:09 UTC
Build: NetBeans IDE 6.5 (Build 200811100001)
VM: Java HotSpot(TM) Client VM, 11.2-b01, Java(TM) SE Runtime Environment, 1.6.0_12-b04
OS: Windows Vista, 6.0, x86

User Comments:
nagabalaji: I'm trying to setup JNDI datasource by adding a new JDBC resource.  When the new file wizard opens, I'm selecting Categories as "Glassfish" and selecting "JDBC resource".  I'. getting the exception when i clicked "Next".

nagabalaji: I'm trying to setup JNDI datasource by adding a new JDBC resource.  When the new file wizard opens, I'm selecting Categories as "Glassfish" and selecting "JDBC resource".  I'. getting the exception when i clicked "Next".



Stacktrace: 
java.lang.NullPointerException
        at org.netbeans.modules.j2ee.sun.ide.sunresources.wizards.CommonAttributePanel.isValid(CommonAttributePanel.java:196)
        at java.awt.Component.invalidateIfValid(Component.java:2740)
        at java.awt.Component.setLocale(Component.java:1810)
        at javax.swing.JComponent.<init>(JComponent.java:595)
        at javax.swing.JPanel.<init>(JPanel.java:65)
        at javax.swing.JPanel.<init>(JPanel.java:92)
Comment 1 nagabalaji 2009-02-05 06:48:19 UTC
Created attachment 76589 [details]
stacktrace
Comment 2 Vince Kraemer 2009-02-11 05:38:06 UTC
*** Issue 158349 has been marked as a duplicate of this issue. ***
Comment 3 Nitya Doraisamy 2009-02-13 02:37:45 UTC
Fixed in trunk
Comment 4 Vince Kraemer 2009-02-13 14:53:31 UTC
http://hg.netbeans.org/main/rev/e28f6d49ea16
Comment 5 Quality Engineering 2009-02-18 10:18:59 UTC
Integrated into 'main-golden', will be available in build *200902180201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/e28f6d49ea16
User: nityad@netbeans.org
Log: #157965 : Fixes for NPE in isValid calls
Comment 6 Nitya Doraisamy 2009-02-24 18:37:54 UTC
*** Issue 159070 has been marked as a duplicate of this issue. ***
Comment 7 Petr Jiricka 2009-02-27 15:49:46 UTC
Fixed also in 6.5.1/patch3: http://hg.netbeans.org/release65_fixes/rev/9ee0bd06d434
Comment 8 davisn 2009-02-27 23:10:06 UTC
When verified Issue 158349 with Netbean 6.7 trunk build (3/26/2009), I also verified this bug with NB 6.5.1 latest build
(3/28/2009) 
Comment 9 Jaroslav Pospisil 2009-03-05 16:52:22 UTC
verified in NB6.5.1 with Win Vista and JDK1.6.0_13


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo