Bug 157827 - [65cat] isValid overriden in tomcat - NPE on jdk6update12
[65cat] isValid overriden in tomcat - NPE on jdk6update12
Status: VERIFIED FIXED
Product: serverplugins
Classification: Unclassified
Component: Tomcat
6.x
All All
: P2 (vote)
: 6.x
Assigned To: issues@serverplugins
issues@serverplugins
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT, 65fixes3-verified
:
: 158144 158956 (view as bug list)
Depends on:
Blocks: 154624
  Show dependency treegraph
 
Reported: 2009-02-03 09:53 UTC by malakim
Modified: 2009-03-16 16:31 UTC (History)
11 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (28.93 KB, text/plain)
2009-02-03 09:53 UTC, malakim
Details
stacktrace (8.10 KB, text/plain)
2009-02-04 15:25 UTC, cere
Details

Note You need to log in before you can comment on or make changes to this bug.
Description malakim 2009-02-03 09:53:42 UTC
Build: NetBeans IDE Dev (Build 200812180001)
VM: Java HotSpot(TM) Client VM, 11.2-b01, Java(TM) SE Runtime Environment, 1.6.0_12-b04
OS: Windows XP, 5.1, x86

User Comments:
malakim: Trying to add a new Tomcat 6 server to the IDE

GUEST: Went to the "Services" tab, right clicked on "Servers" and selected "Add Server". Selected "Tomcat 6.0" from the "Add Server Instance" windows. Clicked next.

malakim: Trying to add a new Tomcat 6 server to the IDE



Stacktrace: 
java.lang.reflect.UndeclaredThrowableException
        at $Proxy19.actionPerformed(.java:0)
        at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1995)
        at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2318)
        at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:387)
        at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:242)
        at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:236)
Comment 1 malakim 2009-02-03 09:53:52 UTC
Created attachment 76500 [details]
stacktrace
Comment 2 cere 2009-02-04 15:25:00 UTC
Build: NetBeans IDE Dev (Build 200812180001)
VM: Java HotSpot(TM) Client VM, 11.2-b01, Java(TM) SE Runtime Environment, 1.6.0_12-b04
OS: Windows XP, 5.1, x86

User Comments: 
I simply selected a Server from the "Choose Server" list, to add. He rejected my choice (he rejected ALL my choices, actually) and informed me there was a NullPointerException...

Stacktrace: 
java.lang.NullPointerException
        at org.netbeans.modules.tomcat5.wizard.InstallPanelVisual.isHomeValid(InstallPanelVisual.java:462)
        at org.netbeans.modules.tomcat5.wizard.InstallPanelVisual.isValid(InstallPanelVisual.java:608)
        at java.awt.Component.invalidateIfValid(Component.java:2740)
        at java.awt.Component.setLocale(Component.java:1810)
        at javax.swing.JComponent.<init>(JComponent.java:595)
        at javax.swing.JPanel.<init>(JPanel.java:65)
Comment 3 cere 2009-02-04 15:25:10 UTC
Created attachment 76563 [details]
stacktrace
Comment 4 Petr Hejl 2009-02-11 16:39:01 UTC
*** Issue 158144 has been marked as a duplicate of this issue. ***
Comment 5 Petr Hejl 2009-02-11 17:00:20 UTC
Fixed in main 84508af7cb91.
Comment 6 Quality Engineering 2009-02-18 10:13:21 UTC
Integrated into 'main-golden', will be available in build *200902180201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/84508af7cb91
User: phejl@netbeans.org
Log: #157827 [65cat] isValid overriden in tomcat - NPE on jdk6update12
Comment 7 Petr Blaha 2009-02-23 08:43:48 UTC
*** Issue 158956 has been marked as a duplicate of this issue. ***
Comment 8 Jindrich Sedek 2009-02-24 09:11:15 UTC
verified.
NetBeans IDE Dev (Build 200902231810)
Comment 9 Jindrich Sedek 2009-03-05 08:59:07 UTC
verified in 6.5.1
NetBeans IDE 6.5.1 (Build 200903050001)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo