Bug 157790 - Use NodeFactorySupport to create LogicalView
Use NodeFactorySupport to create LogicalView
Status: RESOLVED FIXED
Product: javaee
Classification: Unclassified
Component: App Client
6.x
All All
: P2 (vote)
: 6.x
Assigned To: David Konecny
issues@javaee
:
: 131734 (view as bug list)
Depends on:
Blocks: 105645
  Show dependency treegraph
 
Reported: 2009-02-02 16:18 UTC by Milan Kuchtiak
Modified: 2009-03-18 22:38 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Milan Kuchtiak 2009-02-02 16:18:56 UTC
Use java.common.api's NodeFactorySupport to implement Application Client logical view (ApplClientLogicalViewProvider).
(see j2se project, web project, ejbjar project)

This way the full advantage of functionality related to generated sources can be obtained
Comment 1 David Konecny 2009-02-02 19:22:30 UTC
*** Issue 131734 has been marked as a duplicate of this issue. ***
Comment 2 Petr Jiricka 2009-02-11 17:11:01 UTC
Not an M2 stopper.
Comment 3 David Konecny 2009-03-17 21:42:33 UTC
AppClient's logical view is now created from folder Projects/org-netbeans-modules-j2ee-clientproject/Nodes. WebService
nodes were removed and should be provided by WS modules. 29be79d914aa
Comment 4 Quality Engineering 2009-03-18 22:38:29 UTC
Integrated into 'main-golden', will be available in build *200903181604* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/29be79d914aa
User: David Konecny <dkonecny@netbeans.org>
Log: #157790 - Use NodeFactorySupport to create LogicalView


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo