Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 157729 - hg ignore folder
hg ignore folder
Status: RESOLVED FIXED
Product: versioncontrol
Classification: Unclassified
Component: Mercurial
6.x
All All
: P3 (vote)
: 7.0
Assigned To: issues@versioncontrol
issues@versioncontrol
:
: 126124 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-01 15:10 UTC by kevredon
Modified: 2013-03-06 06:33 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kevredon 2009-02-01 15:10:22 UTC
it is not possible for mercurial to ignore a whole folder within the GUI
the ignore option "toggle ignore" exists for files
the current solution is to edit .hgignore manually, and add the folder
Comment 1 Ondrej Vrabec 2009-11-02 13:37:51 UTC
*** Issue 126124 has been marked as a duplicate of this issue. ***
Comment 2 Ondrej Vrabec 2010-05-28 14:47:27 UTC
fix: http://hg.netbeans.org/cdev/rev/4aeb3755642b
Comment 3 Quality Engineering 2010-05-30 07:10:30 UTC
Integrated into 'main-golden', will be available in build *201005300001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/4aeb3755642b
User: Ondrej Vrabec <ovrabec@netbeans.org>
Log: Issue #157729 - hg ignore folder
Comment 4 ExTexan 2013-03-06 05:43:28 UTC
I'd like to see this issue re-opened.  I have a folder with *many* folders under it, most of which are "contributed" modules which I don't want under version control, but also some custom modules which I DO want to version.

From searches of Mercurial forums, the recommended way to accomplish this is to put the top-level folder in the .hgignore file, then ADD the folders/files that I wish to have under version control.  I have done that, but Netbeans doesn't reflect the added files.  ALL files in that ignored folder appear as unversioned in Netbeans.
Comment 5 Ondrej Vrabec 2013-03-06 06:33:45 UTC
For performance reasons ignored folders are not scanned automatically for versioned files. You should restart the IDE after you make this weird setup. Then all files/folders under the ignored folder will appear as ignored.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo