Bug 157692 - Latest patches modify build-impl.xml, setting path to "/does/not/exist"
Latest patches modify build-impl.xml, setting path to "/does/not/exist"
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: Project
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Jesse Glick
issues@java
:
: 158531 (view as bug list)
Depends on:
Blocks: 137060
  Show dependency treegraph
 
Reported: 2009-01-30 22:32 UTC by Nathan Fiedler
Modified: 2009-05-07 08:14 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
JSwat installer project that demonstrates the issue (204.43 KB, application/x-compressed)
2009-02-24 19:26 UTC, Nathan Fiedler
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nathan Fiedler 2009-01-30 22:32:03 UTC
After installing the latest module updates to NetBeans 6.5, when I open my Java projects the build-impl.xml script is
modified, such that the empty "sourcepath" setting in the javac macrodef is changed to "/does/not/exist". Fine, but this
now generates warning messages every time I build my projects. This is not good.
Comment 1 Jiri Prox 2009-02-03 15:57:40 UTC
This is side effect of issue 137060
Comment 2 Jan Jancura 2009-02-11 08:44:32 UTC
I have no warnings building my projects. Can you specify type of warnings, and your project configuration?
Thanks.
Comment 3 Nathan Fiedler 2009-02-11 18:30:45 UTC
Someone changed something in our project settings and now the placeholder path is not being inserted into our build
files. Creating a new Java project shows the placeholder, but building does not indicate any warnings. I have no idea
what happened. All I can say is multiple members of our team experienced this issue, but now it's gone. Closing as not
reproducible.
Comment 4 malfunction84 2009-02-11 19:10:12 UTC
The same thing happened to me.  It was happening, and now it's not.  The path is now "${web.docbase.dir}" where it was
"/does/not/exist" before.  Why wasn't it ${web.docbase.dir} to begin with?  I'm not sure.  Possibly because I had been
changing that value in the Project Properties dialog, and the default path didn't exist (I had deleted it before).

Issue 158342 may be related...
Comment 5 Marian Mirilovic 2009-02-15 22:25:49 UTC
*** Issue 158531 has been marked as a duplicate of this issue. ***
Comment 6 malfunction84 2009-02-16 03:35:51 UTC
I should note that at the time I built my project and got this warning, that property *was* defined in the Project's
Properties.  It's just that the build-impl.xml file didn't reflect that.
Comment 7 Nathan Fiedler 2009-02-24 18:53:29 UTC
This is happening to me for a Java project. I don't know why it happens for some and not for others, but I can tell you
that it *is* happening and it *does* generate a compiler warning when you build the project. This needs investigation.
Comment 8 malfunction84 2009-02-24 19:06:41 UTC
nlfiedler, can you attach your project?
Comment 9 Nathan Fiedler 2009-02-24 19:26:12 UTC
Created attachment 77316 [details]
JSwat installer project that demonstrates the issue
Comment 10 Jesse Glick 2009-02-24 20:20:57 UTC
If you use -Xlint then you will get this warning. It is harmless; /does/not/exist is used intentionally as, well, a path
which does not exist. Just add -Xlint:-path. Probably j2seproject's build-impl.xml should add this to compiler options
automatically, since path lint is not useful for javac invoked from Ant anyway.
Comment 11 Jesse Glick 2009-03-18 20:00:18 UTC
Reported to cause build errors for those using -Xlint:all -Werror in compiler options.

Suggestion: add to build-impl.xml somewhere (I guess in -init-macrodef-javac):

<property name="empty.dir" location="${build.dir}/empty"/>
<delete dir="${empty.dir}" quiet="true"/>
<mkdir dir="${empty.dir}"/>

and then use ${empty.dir} in place of /does/not/exist. I think that would also keep issue #137060 fixed while
eliminating the warning.
Comment 12 malfunction84 2009-03-18 20:32:33 UTC
So if I understand the issue correctly, you must define a default sourcepath for the javac task so it won't attempt to
compile source files included in .jar files.  Previously, it was a path which does not exist, but that was causing
problems, so the proposal is to make it an empty path which does exist.

I don't understand why that needs to be an empty path, though.  Why can't it be ${src.dir}?
Comment 13 pgebauer 2009-04-08 13:59:39 UTC
The status whiteboard "65fixes4-candidate" has been removed.
At this time our proactive patches for the NetBeans 6.5.x IDE have concluded.

If you own a Sun service plan contract for NetBeans, you may wish to contact
Sun Service http://www.sun.com/contact/support.jsp to request a fix via the
product defect escalation process.

For more information on purchasing a Sun service plan contract for NetBeans,
refer to the service plan item "Sun Software Service Plans (S3P) for Developers"
in the Sun Service table found on our NetBeans Support Resources
page http://www.netbeans.org/kb/support.html
Comment 14 Jiri Kovalsky 2009-05-05 15:53:37 UTC
Jesse, would you be willing to fix this?
Comment 15 Jesse Glick 2009-05-05 18:59:04 UTC
core-main #6ea25133eb28
Comment 16 Quality Engineering 2009-05-07 08:14:53 UTC
Integrated into 'main-golden', will be available in build *200905070201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/6ea25133eb28
User: Jesse Glick <jglick@netbeans.org>
Log: #157692: do not use /does/not/exist as javac -Xlint -Werror rejects it. Create build/empty instead.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo