Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 157497 - Can't Refactor Method Signature
Can't Refactor Method Signature
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: Hints
6.x
All All
: P3 (vote)
: 7.1
Assigned To: Ralph Ruijs
issues@java
:
: 126934 (view as bug list)
Depends on:
Blocks: 65780
  Show dependency treegraph
 
Reported: 2009-01-27 13:46 UTC by opticyclic
Modified: 2011-07-14 14:26 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description opticyclic 2009-01-27 13:46:26 UTC
If you create a method with a certain signature then realise when you are using it you want to pass different 
parameters you can't refactor the method signature to what you want.
e.g
Create a method
    private static void test(int numberTest) {
        
    }

Start to use it
    public static void main(String[] args){

        String stringTest="";
        test(stringTest);

    }

At this point, the only refactoring fix is to create a new method, rather than to refactor change the signature of the 
current method.
Comment 1 Jiri Prox 2009-01-27 14:09:54 UTC
Yes, this kind of refactoring is not supported yet. 
Changing this issue to enhancement since it's place for improvement current features
Comment 2 Ralph Ruijs 2011-07-11 08:25:59 UTC
*** Bug 126934 has been marked as a duplicate of this bug. ***
Comment 3 Ralph Ruijs 2011-07-13 08:51:01 UTC
changeset:   196925:b0817ec45a11
user:        Ralph Benjamin Ruijs <ralphbenjamin@netbeans.org>
date:        Tue Jul 12 16:34:09 2011 +0200
summary:     Issue #157497 - Can't Refactor Method Signature
Comment 4 Quality Engineering 2011-07-14 14:26:34 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/b0817ec45a11
User: Ralph Benjamin Ruijs <ralphbenjamin@netbeans.org>
Log: Issue #157497 - Can't Refactor Method Signature


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo