Bug 157300 - Local Variables window: values are not shown
Local Variables window: values are not shown
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Outline&TreeTable
6.x
All All
: P1 with 1 vote (vote)
: 6.x
Assigned To: Jiri Rechtacek
issues@platform
RELNOTE, 65fixes3-verified
: JDK_SPECIFIC, RELNOTE
: 156650 157815 157848 157908 157912 158040 158058 158123 158267 158273 158362 158471 158562 158593 158946 159076 159287 159375 159569 159581 159629 159943 160139 160346 160774 163696 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-22 11:45 UTC by Alexandr Scherbatiy
Modified: 2009-04-27 09:06 UTC (History)
11 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
screenshot (7.67 KB, image/png)
2009-01-29 16:48 UTC, Adam Sotona
Details
IDE screen-shot. Variable valuse are not shown. JDK 6u12 (227.91 KB, image/png)
2009-01-30 10:17 UTC, Alexandr Scherbatiy
Details
IDE screen-shot. Variable valuse are not shown. JDK 6u12 (png format) (227.91 KB, image/png)
2009-01-30 10:20 UTC, Alexandr Scherbatiy
Details
IDE screen-shot. Variable valuse are not shown. JDK 6u12 (png format) (93.41 KB, image/png)
2009-01-30 10:23 UTC, Alexandr Scherbatiy
Details
There are more errors like the attach window - it's broker as well. (36.70 KB, image/png)
2009-02-17 14:17 UTC, witoldsz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandr Scherbatiy 2009-01-22 11:45:13 UTC
JavaFX_NB_Plugin_Franca_NB_65_fixes #50 22-Jan-2009 00:11:59

  Product Version         = NetBeans IDE 6.5 (Build 200811100001)
  Operating System        = Windows XP version 5.1 running on x86
  Java; VM; Vendor        = 1.6.0_12-ea; Java HotSpot(TM) Client VM 11.2-b01; Sun Microsystems Inc.

Steps to reproduce:

- Copy the code to the editor:
-----------------------------------------
var a = 10;
var b = 20;
-----------------------------------------

- Set a breakpoint to the 'b' variable
- Start the Debugger
- Go to the Local Variables window
  The variable values are not shown.
Comment 1 Adam Sotona 2009-01-23 17:19:07 UTC
How did you manage to run JavaFX_NB_Plugin_Franca_NB_65_fixes on NB Build #200811100001?
Even when there is reported issue #157293 about not working update.
Comment 2 Alexandr Scherbatiy 2009-01-26 09:55:08 UTC
The issue is reproduced with 
JavaFX_NB_Plugin_Franca_NB_65_fixes_promoted_SDK_installer: #16 24-Jan-2009 01:21:44

  Product Version         = NetBeans IDE 6.5 (Build 200901231801)
  Operating System        = Windows XP version 5.1 running on x86
  Java; VM; Vendor        = 1.6.0_12-ea; Java HotSpot(TM) Client VM 11.2-b01; Sun Microsystems Inc.


Probably because of the JDK 6u12.
Comment 3 Adam Sotona 2009-01-29 16:47:30 UTC
For me it works - see attached screenshot.
Comment 4 Adam Sotona 2009-01-29 16:48:07 UTC
Created attachment 76350 [details]
screenshot
Comment 5 Alexandr Scherbatiy 2009-01-30 10:17:50 UTC
Created attachment 76368 [details]
IDE screen-shot. Variable valuse are not shown. JDK 6u12
Comment 6 Alexandr Scherbatiy 2009-01-30 10:20:15 UTC
Created attachment 76369 [details]
IDE screen-shot. Variable valuse are not shown. JDK 6u12 (png format)
Comment 7 Alexandr Scherbatiy 2009-01-30 10:23:22 UTC
Created attachment 76370 [details]
IDE screen-shot. Variable valuse are not shown. JDK 6u12 (png format)
Comment 8 Alexandr Scherbatiy 2009-01-30 10:27:54 UTC
Please, see the latest attached IDE screenshot.
It is reproduced with JDK 6u12 from:
http://download.java.net/jdk6
Comment 9 Adam Sotona 2009-01-30 11:36:46 UTC
The same problem applies to all Java Debugger. Local variables are not show at all for the JDK 6u12 EA
Please fill an issue on JDK.
I think we should recommend to do not use JDK 6u12 EA and someone from debugger team should investigate the reason.
Comment 10 Martin Entlicher 2009-02-03 09:23:31 UTC
I'll look at it...
Comment 11 Martin Entlicher 2009-02-03 10:14:19 UTC
A bug in Outline View.
No property values are displayed in all tables.
You can verify in Local History that this is not a debugger issue.
Comment 12 Martin Entlicher 2009-02-03 10:17:10 UTC
In NB 6.5 debugger did not use an outline view. It was based on TreeTableView.
Therefore this can also be a defect of JTable.
Comment 13 swpalmer 2009-02-03 14:53:39 UTC
I'm having the same issue.  It is with the released 6u12, not an early access version.
Variable values are shown in the tooltip in the editor window during debugging (showing that the value is readable from 
the JVM), but not in the Local Variables window.
Comment 14 Jiri Rechtacek 2009-02-03 15:08:44 UTC
Seems as a jdkbug, will be reported soon.
Comment 15 Martin Entlicher 2009-02-03 15:17:36 UTC
*** Issue 157848 has been marked as a duplicate of this issue. ***
Comment 16 swpalmer 2009-02-03 15:29:27 UTC
Is there a different mechanism for getting the values to show in the Local Variables window?
I ask because as I stated above, the correct value shows in the editor window tool tip when you hover over a variable 
name, and the local variable names are listed in the Local Variables window.. so with that information I would expect 
the values could be populated in the window the same way they are acquired for the tool tip.
Comment 17 Martin Entlicher 2009-02-03 17:09:47 UTC
swpalmer, this problem is NOT in debugger. The table IS populated with correct values. But the values are not displayed.
The bug is in the UI.
Comment 18 Martin Entlicher 2009-02-04 12:54:43 UTC
*** Issue 157908 has been marked as a duplicate of this issue. ***
Comment 19 Martin Entlicher 2009-02-04 12:56:21 UTC
*** Issue 157908 has been marked as a duplicate of this issue. ***
Comment 20 Martin Entlicher 2009-02-04 12:57:11 UTC
*** Issue 157908 has been marked as a duplicate of this issue. ***
Comment 21 Martin Entlicher 2009-02-04 12:58:25 UTC
Can you please provide the JDK bug for reference? Thanks.
Comment 22 Martin Entlicher 2009-02-04 13:27:57 UTC
*** Issue 157912 has been marked as a duplicate of this issue. ***
Comment 23 computerjy 2009-02-04 13:52:39 UTC
I don't know how is the table generated but when the tooltip is showing the correct values
Comment 24 vieiro 2009-02-05 11:51:06 UTC
This happens in 

SunOS antonio 5.11 snv_101b i86pc i386 i86pc Solaris

as well.
Comment 25 ranbato 2009-02-05 16:17:01 UTC
I haven't gotten far enough to tell about the local variable issue, but if I try to attach to a process with 6u12
everything under the divider in the Attach dialog is missing.  
In other words, the Debugger: dropdown and label and the buttons are the only controls in the dialog.
Comment 26 Jiri Rechtacek 2009-02-06 08:51:46 UTC
*** Issue 158040 has been marked as a duplicate of this issue. ***
Comment 27 Jiri Rechtacek 2009-02-06 09:03:19 UTC
I'm investigating which changeset in sources in JDK6u12 made broken TreeTableView and OutlineView too....
Comment 28 Jiri Rechtacek 2009-02-06 17:01:00 UTC
fixed in rev/39b9fb269554 (will be in Dev builds in few days)
Comment 29 Quality Engineering 2009-02-07 08:39:36 UTC
Integrated into 'main-golden', will be available in build *200902070301* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/39b9fb269554
User: Jiri Rechtacek <jrechtacek@netbeans.org>
Log: #157300: TreeTableView and OutlineView: values are not shown
Comment 30 Jiri Rechtacek 2009-02-08 13:59:03 UTC
*** Issue 157815 has been marked as a duplicate of this issue. ***
Comment 31 Jaromir Uhrik 2009-02-09 13:30:56 UTC
Before the fix the following JDK's were tested on Win XP:
JDK6 update 11 fcs: issue cannot be reproducible
JDK6 update 12 ea1: 100% reproducible
JDK6 update 12 ea2: 100% reproducible
JDK6 update 12 ea3: 100% reproducible
JDK6 update 12 fcs: 100% reproducible
JDK6 update 13 ea1: 100% reproducible 
Comment 32 Jaromir Uhrik 2009-02-09 13:31:47 UTC
Verified in the following build:

Product Version: NetBeans IDE Dev (Build 200902090201)
Java: 1.6.0_13-ea; Java HotSpot(TM) Server VM 11.3-b01
System: Windows XP version 5.1 running on x86; Cp1252; en_US (nb)
Comment 33 rmichalsky 2009-02-10 10:33:47 UTC
*** Issue 158123 has been marked as a duplicate of this issue. ***
Comment 34 Martin Entlicher 2009-02-10 11:44:12 UTC
*** Issue 158267 has been marked as a duplicate of this issue. ***
Comment 35 Martin Entlicher 2009-02-10 11:44:24 UTC
*** Issue 158273 has been marked as a duplicate of this issue. ***
Comment 36 Martin Entlicher 2009-02-11 13:20:45 UTC
*** Issue 158058 has been marked as a duplicate of this issue. ***
Comment 37 t_h 2009-02-11 17:28:38 UTC
*** Issue 156650 has been marked as a duplicate of this issue. ***
Comment 38 lkishalmi 2009-02-12 10:13:18 UTC
Verified the patch on release65-fixes and it works with NetBeans 6.5 as well.
I hope there will be a patch released for this issue soon. I have some new NetBeans users (coming from eclipse) and it
is a bit abashing applying this jar manually on their IDE after they just downloaded the latest JDK+IDE bundle and
waiting for the out of the box experience.
Comment 39 Martin Entlicher 2009-02-13 16:43:53 UTC
*** Issue 158362 has been marked as a duplicate of this issue. ***
Comment 40 Martin Entlicher 2009-02-13 16:44:40 UTC
Upgrading to P1 due to the number of bugreports.
Comment 41 Martin Entlicher 2009-02-14 13:14:20 UTC
*** Issue 158562 has been marked as a duplicate of this issue. ***
Comment 42 brettryan 2009-02-16 03:47:47 UTC
I understand that a fix is in place with NetBeans, though is this really an issue with the JDK instead? Has this bug
been identified with the JDK?
Comment 43 lkishalmi 2009-02-16 08:49:31 UTC
I don't think that this is a JDK bug. As Java makes steps toward mixing heavy weight components with light weight
components some performance "assumptions" became wrong. Like in this case we just assume that the cell renderers always
valid, so for gain some performance boost the isValid() method returned simply true. This is not the case when there are
heavyweight components presented as well.
Comment 44 Martin Entlicher 2009-02-16 10:20:16 UTC
*** Issue 158593 has been marked as a duplicate of this issue. ***
Comment 45 Ondrej Vrabec 2009-02-17 12:14:40 UTC
*** Issue 158471 has been marked as a duplicate of this issue. ***
Comment 46 witoldsz 2009-02-17 14:17:42 UTC
Created attachment 77070 [details]
There are more errors like the attach window - it's broker as well.
Comment 47 Martin Entlicher 2009-02-17 14:21:02 UTC
We have a different issue for Attach dialog - issue #158192. It's already fixed as well.
Comment 48 brettryan 2009-02-18 07:54:50 UTC
@mentlicher

Thanks for the update, will these fixes be back-ported to 6.5 or will we be required to continue using JDK6U11 or
earlier until 7.0 comes out?

Thankyou,
-Brett
Comment 49 Martin Entlicher 2009-02-18 10:52:09 UTC
brettryan, it depends on sustaining team. pgebauer, do you know when can we expect 65patch3? This and issue #158192
contain must-have fixes to be able to work on JDK 6u12.
Comment 50 jianwu 2009-02-24 01:46:45 UTC
I faced the same problem today after I setup a new laptop. Both Netbeans 6.5 and Netbean7 can't work. Where can i find
the patch?
Comment 51 Martin Entlicher 2009-02-24 10:21:15 UTC
There's no patch for 6.5 yet. We will mention the availability of the patch here after it's ready.

The issue is fixed in recent 6.7 builds (former 7.0).
Comment 52 Martin Entlicher 2009-02-24 16:18:55 UTC
*** Issue 159076 has been marked as a duplicate of this issue. ***
Comment 53 Martin Entlicher 2009-02-25 14:05:01 UTC
*** Issue 158946 has been marked as a duplicate of this issue. ***
Comment 54 Jiri Rechtacek 2009-02-25 14:22:36 UTC
backported to Nb6.5; http://hg.netbeans.org/release65_fixes/rev/cb01b33ad78c
Comment 55 Martin Entlicher 2009-02-27 10:31:44 UTC
*** Issue 159287 has been marked as a duplicate of this issue. ***
Comment 56 Filip Zamboj 2009-02-27 11:29:20 UTC
verified for Product Version: NetBeans IDE 6.5.1 (Build 200902270001)
Comment 57 Martin Entlicher 2009-03-01 09:00:02 UTC
*** Issue 159375 has been marked as a duplicate of this issue. ***
Comment 58 ulfzibis 2009-03-01 11:30:51 UTC
Please notify users about this problem in newsletter + news on homepage? (Maybe overseen, but I normally read all)
Comment 59 Jiri Rechtacek 2009-03-04 09:22:02 UTC
*** Issue 159569 has been marked as a duplicate of this issue. ***
Comment 60 tboerkel 2009-03-04 09:29:33 UTC
It would be good, if this would be available as online patch for NetBeans 6.0/6.1 also. Our customers won't upgrade to
6.5 soon.
Comment 61 Martin Entlicher 2009-03-04 17:48:55 UTC
*** Issue 159629 has been marked as a duplicate of this issue. ***
Comment 62 Filip Zamboj 2009-03-05 15:12:52 UTC
verified on 
Product Version: NetBeans IDE 6.5.1 (Build 200903050001)
Java: 1.6.0_12; Java HotSpot(TM) 64-Bit Server VM 11.2-b01
System: Linux version 2.6.27-11-generic running on amd64; UTF-8; en_US (nb)
Userdir: /home/felipee/SUN/userdirs/651_mar05_2
Comment 63 Martin Entlicher 2009-03-06 13:39:36 UTC
*** Issue 159581 has been marked as a duplicate of this issue. ***
Comment 64 Martin Entlicher 2009-03-10 15:42:53 UTC
*** Issue 159943 has been marked as a duplicate of this issue. ***
Comment 65 shawnho 2009-03-12 03:32:07 UTC
I saw there is a fixed backported to 6.5. Do we have to have the source in order to apply this fix? 
Comment 66 Martin Entlicher 2009-03-13 10:08:25 UTC
*** Issue 160139 has been marked as a duplicate of this issue. ***
Comment 67 rmichalsky 2009-03-19 11:30:58 UTC
*** Issue 160346 has been marked as a duplicate of this issue. ***
Comment 68 Martin Entlicher 2009-03-23 11:45:31 UTC
*** Issue 160774 has been marked as a duplicate of this issue. ***
Comment 69 Martin Entlicher 2009-04-27 09:06:23 UTC
*** Issue 163696 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo