Bug 157287 - Startup message
Startup message
Status: RESOLVED WONTFIX
Product: java
Classification: Unclassified
Component: Compiler
6.x
All All
: P4 (vote)
: TBD
Assigned To: Dusan Balek
issues@java
: ERGONOMICS
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-22 03:36 UTC by Vince Kraemer
Modified: 2009-02-19 21:09 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vince Kraemer 2009-01-22 03:36:44 UTC
Cannot create library: javac-api of unknown type: j2se

I also see a similar for messages for jaxb, MySQLDriver, PostgressSQLDriver at start up.
Comment 1 Vince Kraemer 2009-01-22 03:41:22 UTC
this may be related to issue 156658... If there is link between the this and 156658, please let me know.
Comment 2 Vince Kraemer 2009-01-23 21:52:48 UTC
I was able to reproduce this with a recently pulled build.

I was able to make these messages 'go away' by removing the ergonomics code (by right-click 'Clean' on the project) from
the built IDE.
Comment 3 Jaroslav Tulach 2009-01-24 09:28:30 UTC
This message appears because ide cluster has runtime dependencies on java cluster which is not enabled. E.g. it 
registers java libraries which are only handled when the java cluster is enabled. The message is correct and harmless 
(lowering priority). The behaviour is OK, as soon as you enable Java cluster: as such I suggest "won't fix".


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo