Bug 157268 - All web html related templates are no longer working
All web html related templates are no longer working
Status: RESOLVED FIXED
Product: javaee
Classification: Unclassified
Component: Code
6.x
All All
: P2 (vote)
: 6.x
Assigned To: issues@javaee
issues@javaee
: ERGONOMICS
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-21 19:21 UTC by _ potingwu
Modified: 2009-02-19 23:27 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ potingwu 2009-01-21 19:21:52 UTC
When creating new file by selecting category Web, the file types HTML and XHTML are no longer working! Sometimes I got
error mesg under the wizard shows "... org/netbeans/modules/html/templates/xhtml.xhtml cannot be found" or the wizard
just shows "Requested functionality not found!"!

I think it is caused by the recent 'ergonomics' scheme because it will work after I added the following runtime
dependency in web.core module:
                <dependency>
                    <code-name-base>org.netbeans.modules.html</code-name-base>
                    <build-prerequisite/>
                    <run-dependency>
                        <release-version>1</release-version>
                        <specification-version>1.25</specification-version>
                    </run-dependency>
                </dependency>

More serious issue: All html/xhtml file objects cannot be identified because the html module is not 'activated'! All
html editor functions are then disabled!! It affects all frameworks that use html/xhtml. E.g., the Facelets!
Comment 1 Petr Jiricka 2009-02-12 17:22:23 UTC
Works for me in build 5020 from deadlock. Marking as FIXED.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo