Bug 157243 - org.netbeans.modules.db.metadata.model.api.MetadataModelException: org.netbeans.modules.db.metadata.model.api.MetadataException: java.sql.SQLException: Invalid state, the Connection object is closed.
org.netbeans.modules.db.metadata.model.api.MetadataModelException: org.netbea...
Status: RESOLVED WORKSFORME
Product: db
Classification: Unclassified
Component: Code
6.x
All All
: P3 (vote)
: 7.2
Assigned To: Jaroslav Havlin
issues@db
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
: RANDOM
: 163655 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-21 15:27 UTC by Roman Mostyka
Modified: 2012-06-05 16:06 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (4.29 KB, text/plain)
2009-01-21 15:27 UTC, Roman Mostyka
Details
dialog (16.69 KB, image/jpeg)
2009-04-30 09:24 UTC, bartvdc
Details
stacktrace (3.85 KB, text/plain)
2009-09-02 01:55 UTC, Exceptions Reporter
Details
stacktrace (3.88 KB, text/plain)
2009-10-16 09:14 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Mostyka 2009-01-21 15:27:08 UTC
Build: NetBeans IDE Dev (Build 090120)
VM: Java HotSpot(TM) Client VM, 1.5.0_16-133, Java(TM) 2 Runtime Environment, Standard Edition, 1.5.0_16-b06-284
OS: Mac OS X, 10.5.6, i386

User Comments:
romanmostyka: 1. Add jTDS driver.
2. Add connection to MS SQL Server using this driver.
3. Connect to it.
4. Disconnect.

Result: I repeated steps 3 and 4 several times and MetadataModelException arises.



Stacktrace: 
org.netbeans.modules.db.metadata.model.api.MetadataModelException: org.netbeans.modules.db.metadata.model.api.MetadataException: java.sql.SQLException: Invalid state, the Connection object is closed.
        at org.netbeans.modules.db.metadata.model.JDBCConnMetadataModel.runReadAction(JDBCConnMetadataModel.java:99)
        at org.netbeans.modules.db.metadata.model.api.MetadataModel.runReadAction(MetadataModel.java:89)
        at org.netbeans.modules.db.explorer.node.ViewNodeProvider.initialize(ViewNodeProvider.java:98)
        at org.netbeans.api.db.explorer.node.NodeProvider.getNodes(NodeProvider.java:103)
        at org.netbeans.modules.db.explorer.node.NodeRegistry.getNodes(NodeRegistry.java:149)
        at org.netbeans.api.db.explorer.node.ChildNodeFactory.createKeys(ChildNodeFactory.java:104)
Comment 1 Roman Mostyka 2009-01-21 15:27:19 UTC
Created attachment 76101 [details]
stacktrace
Comment 2 Jiri Rechtacek 2009-02-10 15:19:44 UTC
Reassigned to new owner.
Comment 3 bartvdc 2009-04-30 09:21:52 UTC
I get similar when invoking code completion in a query to get the column names.
It adds : Invalid descriptor index
The connection is to sql server DB through an odbc link. It just shows a dialog, no reporting possible.
see dialog in attach.
Comment 4 bartvdc 2009-04-30 09:24:25 UTC
Created attachment 81277 [details]
dialog
Comment 5 Jiri Rechtacek 2009-04-30 15:27:33 UTC
*** Issue 163655 has been marked as a duplicate of this issue. ***
Comment 6 Jiri Rechtacek 2009-07-01 07:44:42 UTC
NB6.7 was released already - http://www.netbeans.org/community/releases/67/
Postpone fixing this issue on the next release.
Comment 7 Exceptions Reporter 2009-09-02 01:55:52 UTC
Build: NetBeans IDE 6.7.1 (Build 200907230233)
VM: Java HotSpot(TM) Client VM, 14.0-b16, Java(TM) SE Runtime Environment, 1.6.0_14-b08
OS: Windows XP, 5.1, x86

User Comments: 


Stacktrace: 
java.net.SocketException: socket closed
        at java.net.SocketInputStream.socketRead0(SocketInputStream.java:0)
        at java.net.SocketInputStream.read(SocketInputStream.java:129)
        at com.mysql.jdbc.util.ReadAheadInputStream.fill(ReadAheadInputStream.java:113)
        at com.mysql.jdbc.util.ReadAheadInputStream.readFromUnderlyingStreamIfNecessary(ReadAheadInputStream.java:160)
        at com.mysql.jdbc.util.ReadAheadInputStream.read(ReadAheadInputStream.java:188)
        at com.mysql.jdbc.MysqlIO.readFully(MysqlIO.java:2428)
Comment 8 Exceptions Reporter 2009-09-02 01:55:56 UTC
Created attachment 86947 [details]
stacktrace
Comment 9 Exceptions Reporter 2009-09-02 01:56:01 UTC
This issue already has 6 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=145423
Comment 10 Exceptions Reporter 2009-10-16 09:14:44 UTC
Build: NetBeans IDE 6.8 M2 (Build 200910071658)
VM: Java HotSpot(TM) Client VM, 14.2-b01, Java(TM) SE Runtime Environment, 1.6.0_16-b01
OS: Windows XP, 5.1, x86

User Comments: 
Selected the Tables node in the Services tree for a MySQL database when error occurred.

Stacktrace: 
java.net.SocketException: Software caused connection abort: recv failed
        at java.net.SocketInputStream.socketRead0(SocketInputStream.java:0)
        at java.net.SocketInputStream.read(SocketInputStream.java:129)
        at com.mysql.jdbc.util.ReadAheadInputStream.fill(ReadAheadInputStream.java:113)
        at com.mysql.jdbc.util.ReadAheadInputStream.readFromUnderlyingStreamIfNecessary(ReadAheadInputStream.java:160)
        at com.mysql.jdbc.util.ReadAheadInputStream.read(ReadAheadInputStream.java:188)
        at com.mysql.jdbc.MysqlIO.readFully(MysqlIO.java:2428)
Comment 11 Exceptions Reporter 2009-10-16 09:14:49 UTC
Created attachment 89593 [details]
stacktrace
Comment 12 Exceptions Reporter 2009-10-16 09:14:54 UTC
This issue already has 7 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=145423
Comment 13 Jaroslav Havlin 2012-06-05 16:06:50 UTC
Cannot reproduce. The bug seems to be already fixed.
Closing. Please reopen if you can encounter this problem again. Thanks.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo