Bug 157152 - The "Find" component on bottom of editor should remain
The "Find" component on bottom of editor should remain
Status: VERIFIED FIXED
Product: editor
Classification: Unclassified
Component: Search
6.x
All All
: P4 with 1 vote (vote)
: 7.1
Assigned To: Milutin Kristofic
issues@editor
:
: 128597 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-20 18:17 UTC by tomwheeler
Modified: 2011-08-16 14:42 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tomwheeler 2009-01-20 18:17:26 UTC
If you are editing a file and press Ctrl+F, the "find" component will be displayed at the bottom of the editor window. 
However, this disappears as soon as you bring focus to the editor text area or if you bring focus to any other TopComponent.

It would be better if the "find" component remained active and visible until explicitly closed, and was not "owned" by
any particular editor TopComponent.  This is how Firefox works and that design makes it easy to repeat a search in
another window (or in the case of Firefox, another tab).  I realize that you can do a "find in files" search in the
IDE's projects tab, but there are times when you want to limit the search to a few specific files, especially if they
are not rooted in the same project.
Comment 1 Michel Graciano 2011-08-03 00:55:44 UTC
Maybe this is related http://netbeans.org/bugzilla/show_bug.cgi?id=192318
Comment 2 Milutin Kristofic 2011-08-03 09:50:52 UTC
Ok, I will try to implement this one.
Comment 3 Milutin Kristofic 2011-08-03 09:51:26 UTC
*** Bug 128597 has been marked as a duplicate of this bug. ***
Comment 4 Milutin Kristofic 2011-08-12 09:59:07 UTC
It's implemented http://hg.netbeans.org/jet-main/rev/cec9d7fe6cee

Searchbar is closed by pressing ESC, or by click to close button. (Or There is different behavior if you use emacs profile).

Searchbar remains at the bottom of editor. It has focus also when you open new file, change a file. It doesn't have focus, if focus was on editor not on search text field.
Comment 5 Quality Engineering 2011-08-13 14:15:52 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/cec9d7fe6cee
User: Milutin Kristofic <mkristofic@netbeans.org>
Log: #157152 - enhancement - searchbar is singleton, remain on bottom
Comment 6 tomwheeler 2011-08-16 14:42:13 UTC
Excellent!  I have verified the fix in the following environment.

Product Version: NetBeans IDE Dev (Build 201108140601)
Java: 1.6.0_25; Java HotSpot(TM) Client VM 20.0-b11
System: Windows XP version 5.1 running on x86; Cp1252; en_US (nb)

Thank you so much!


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo