Bug 157117 - AssertionError: Attempt to fire an unsupported property change event from org.netbeans.modules.ide.ergonomics.fod.FeatureProjectFactory$FeatureDelegate: null
AssertionError: Attempt to fire an unsupported property change event from org...
Status: RESOLVED DUPLICATE of bug 161856
Product: projects
Classification: Unclassified
Component: Generic Projects UI
6.x
All All
: P4 (vote)
: 6.x
Assigned To: Milan Kubec
issues@projects
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
: ERGONOMICS
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-20 11:06 UTC by Tomas Danek
Modified: 2009-04-09 12:20 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (2.80 KB, text/plain)
2009-01-20 11:06 UTC, Tomas Danek
Details
Patch to make the code more robust (in my opinion) (983 bytes, patch)
2009-01-28 11:29 UTC, Jaroslav Tulach
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Danek 2009-01-20 11:06:28 UTC
Build: NetBeans IDE Dev (Build 200901200201)
VM: Java HotSpot(TM) Client VM, 11.0-b11, Java(TM) SE Runtime Environment, 1.6.0_10-beta-b14
OS: Linux, 2.6.27-9-generic, i386

User Comments:
musilt2: - unzipped full IDE (i.e. with ergonomics cluster)
- started with --open <project_folder>
- i guess "entry point" is missing for this case - AE was thrown



Stacktrace: 
java.lang.AssertionError: Attempt to fire an unsupported property change event from org.netbeans.modules.ide.ergonomics.fod.FeatureProjectFactory$FeatureDelegate: null
        at org.netbeans.modules.project.ui.PhysicalView$GroupNode$1.run(PhysicalView.java:310)
        at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
        at java.awt.EventQueue.dispatchEvent(EventQueue.java:597)
        at org.netbeans.core.TimableEventQueue.dispatchEvent(TimableEventQueue.java:104)
        at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:284)
        at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
Comment 1 Tomas Danek 2009-01-20 11:06:44 UTC
Created attachment 76028 [details]
stacktrace
Comment 2 Tomas Danek 2009-01-20 11:10:02 UTC
no project action (Run, Build,...),  are enabled. project does not seem to be loaded ok.  
Comment 3 Jaroslav Tulach 2009-01-28 11:28:24 UTC
I am not able to reproduce the problem, but looking at the code the propertyChange method in PhysicalView$GroupNode 
does not expect that someone will firePropertyChange(null, null, null). As that is valid according to JavaBean 
specification, the code is very likely wrong.
Comment 4 Jaroslav Tulach 2009-01-28 11:29:33 UTC
Created attachment 76293 [details]
Patch to make the code more robust (in my opinion)
Comment 5 Jaroslav Tulach 2009-04-09 12:20:40 UTC

*** This issue has been marked as a duplicate of 161856 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo