Bug 15698 - Corrupted bundle after adding new property via table
Corrupted bundle after adding new property via table
Status: CLOSED FIXED
Product: utilities
Classification: Unclassified
Component: Properties
3.x
PC Windows ME/2000
: P1 (vote)
: 3.x
Assigned To: issues@utilities
issues@utilities
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-20 13:57 UTC by Martin Roskanin
Modified: 2003-07-01 14:21 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Roskanin 2001-09-20 13:57:39 UTC
After the addition of new key and value via table, the source of bundle is corrupted. The newly property is added in the middle of code. It is 
dataloss, so I am giving priority P1 for that issue. It is easily reproducable on windows.
Comment 1 Peter Zavadsky 2001-09-20 14:17:28 UTC
Fixed in [main-trunk]. Next build available.

Problem was caused by document's conversion of line endings when
parsing buffer was created from on file input stream, thus elements
had wrong bounds created.

There was also problem with updating bounds of internal properties
structuer which caused programatical adding of new items into a middle
of fiel instead of at the end.
Comment 2 pfelenda 2002-10-17 12:37:15 UTC
Verified in release 332 and dev build 200216100100.
Comment 3 Quality Engineering 2003-07-01 14:21:02 UTC
Resolved for 3.4.x or earlier, no new info since then -> closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo