Bug 156878 - NullPointerException at org.netbeans.modules.cnd.makeproject.ui.wizards.NewMakeProjectWizardIterator.instantiate
NullPointerException at org.netbeans.modules.cnd.makeproject.ui.wizards.NewMa...
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: -- Other --
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Alexander Simon
issues@cnd
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT 65fixes3-fixed
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-15 12:07 UTC by Marian Mirilovic
Modified: 2009-03-16 16:33 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marian Mirilovic 2009-01-15 12:07:49 UTC
16 duplicates so far ... reported also against NB 6.5

Build: NetBeans IDE 6.0 (Build 200711261600)
VM: Java HotSpot(TM) 64-Bit Server VM, 1.6.0_03-b05
OS: Linux, 2.6.23-gentoo-r1, amd64
User comments: Tried to import an existing C++ project
STACKTRACE: (first 10 lines)
java.lang.NullPointerException
        at
org.netbeans.modules.cnd.makeproject.ui.wizards.NewMakeProjectWizardIterator.instantiate(NewMakeProjectWizardIterator.java:245)
        at org.openide.loaders.TemplateWizard$InstantiatingIteratorBridge.instantiate(TemplateWizard.java:1025)
        at org.openide.loaders.TemplateWizard.handleInstantiate(TemplateWizard.java:595)
        at org.openide.loaders.TemplateWizard.instantiateNewObjects(TemplateWizard.java:416)
        at org.openide.loaders.TemplateWizardIterImpl.instantiate(TemplateWizardIterImpl.java:248)
        at org.openide.loaders.TemplateWizardIteratorWrapper.instantiate(TemplateWizardIteratorWrapper.java:161)
        at org.openide.WizardDescriptor.callInstantiateOpen(WizardDescriptor.java:1387)
        at org.openide.WizardDescriptor.callInstantiate(WizardDescriptor.java:1341)
        at org.openide.WizardDescriptor.access$1600(WizardDescriptor.java:119)
        at org.openide.WizardDescriptor$Listener$2$1.run(WizardDescriptor.java:1908)
Comment 1 Alexander Simon 2009-01-20 12:54:04 UTC
fixed, change set:
http://hg.netbeans.org/main/rev/1aea8b044a12
QA: evaluate, please, issue. Should the issue be fixed in NB 6.0, 6.1 and 6.5 also?
Comment 2 nethippo 2009-01-23 06:41:57 UTC
I was using it SunStudio on the locale, ko with UTF-8 encoding.
Comment 3 Quality Engineering 2009-01-23 07:32:34 UTC
Integrated into 'main-golden', will be available in build *200901230201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/1aea8b044a12
User: Alexander Simon <alexvsimon@netbeans.org>
Log: fixed IZ#156878:NullPointerException at org.netbeans.modules.cnd.makeproject.ui.wizards.NewMakeProjectWizardIterator.instantiate
Comment 4 Alexander Pepin 2009-01-27 17:11:34 UTC
The issue is fixed in trunk. Should be backported into 6.5 and probably 6.1. Marked as patch3 candidate.
Comment 5 Alexander Pepin 2009-02-26 16:48:45 UTC
verified in build 200902260201
Comment 6 Egor Ushakov 2009-02-27 16:42:45 UTC
integrated into release65_fixes with:
http://hg.netbeans.org/release65_fixes/rev/f94f62ce3a3a


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo