Bug 156715 - CPU goes to 100%, making the IDE unusable
CPU goes to 100%, making the IDE unusable
Status: RESOLVED INVALID
Product: editor
Classification: Unclassified
Component: -- Other --
6.x
Sun All
: P3 (vote)
: 6.x
Assigned To: issues@editor
issues@editor
: RANDOM, THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-13 19:31 UTC by vieiro
Modified: 2009-08-19 11:54 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Thread dump of busy thread (3.19 KB, text/plain)
2009-01-13 20:02 UTC, vieiro
Details
Thread dump of busy thread (4.52 KB, text/plain)
2009-01-13 20:02 UTC, vieiro
Details
Thread dump of busy thread (4.31 KB, text/plain)
2009-01-13 20:03 UTC, vieiro
Details
Thread dump of busy thread (4.51 KB, text/plain)
2009-01-13 20:04 UTC, vieiro
Details
Full stack trace (16.27 KB, text/plain)
2009-01-14 22:46 UTC, vieiro
Details
Full stack trace (16.45 KB, text/plain)
2009-01-14 22:46 UTC, vieiro
Details
Full stack trace (15.38 KB, text/plain)
2009-01-14 22:47 UTC, vieiro
Details

Note You need to log in before you can comment on or make changes to this bug.
Description vieiro 2009-01-13 19:31:21 UTC
This is for NB 6.5 with latest patches, and with jVI installed, on OpenSolaris 8.11.

It happens randomly that the IDE goes to 100% CPU usage and is thus unusable. There's no thread lock I can detect.

I opened "jconsole" and watched the threads there, the "AWT-EventQueue-1" is working as mad, doing different things.

I'm attaching different thread dumps of the "AWT-EventQueue-1" for you to see if there's a loop or something that
prevents the IDE from being responsive again.
Comment 1 vieiro 2009-01-13 20:02:38 UTC
Created attachment 75784 [details]
Thread dump of busy thread
Comment 2 vieiro 2009-01-13 20:02:56 UTC
Created attachment 75785 [details]
Thread dump of busy thread
Comment 3 vieiro 2009-01-13 20:03:29 UTC
Created attachment 75786 [details]
Thread dump of busy thread
Comment 4 vieiro 2009-01-13 20:04:21 UTC
Created attachment 75787 [details]
Thread dump of busy thread
Comment 5 Petr Dvorak 2009-01-14 00:07:31 UTC
Hi, can you reproduce the issue? Also, can you please attach a full thread dump next time this happens, not just the
stack for the AWT-EventQueue thread? Here is how to do that:

http://wiki.netbeans.org/GenerateThreadDump

Use of combination jps (a "ps" for JavaVM) and jstack should be sufficient.
Comment 6 vieiro 2009-01-14 22:46:03 UTC
Happened again, attaching full thread dumps taken with seconds of difference.

Comment 7 vieiro 2009-01-14 22:46:42 UTC
Created attachment 75841 [details]
Full stack trace
Comment 8 vieiro 2009-01-14 22:46:59 UTC
Created attachment 75842 [details]
Full stack trace
Comment 9 vieiro 2009-01-14 22:47:15 UTC
Created attachment 75843 [details]
Full stack trace
Comment 10 Vitezslav Stejskal 2009-01-19 10:05:40 UTC
It's hard to say what is wrong. The AWT thread seems to be updating caret's position and highlighting brackets. If for
some reason this keeps running continuously it could stall the CPU. The question is why is this happening? Do you have a
way how to reproduce it? Could you please try not using jVi for some time to see if it happens without the plugin as
well? Could you also attach the IDE's log file here (<ide-userdir>/var/log/messages.log) just to see if there were any
exceptions? Thanks
Comment 11 Vitezslav Stejskal 2009-02-04 10:25:42 UTC
Since there are no similar reports I assume this does not happen without jVi plugin.
Comment 12 Jiri Prox 2009-08-19 11:28:19 UTC
Unfortunately there is no feedback from reported, I'm afraid that without requested info we cannot do anything about it,
since we weren't able to reproduce it, Closing as Invalid for now.

Feel free to reopen and provide requested info if it is still reproducible
thanks 
Comment 13 vieiro 2009-08-19 11:48:56 UTC
Ok. I wasn't able to reproduce it.
Comment 14 Jiri Prox 2009-08-19 11:54:31 UTC
thanks for verification


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo