Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 156480 - cannot deploy SA with "ERROR" substring in name
cannot deploy SA with "ERROR" substring in name
Status: VERIFIED FIXED
Product: soa
Classification: Unclassified
Component: JBI Manager
6.x
All All
: P2 (vote)
: TBD
Assigned To: Jun Qian
issues@soa
61fixes5-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-08 16:06 UTC by Tientien Li
Modified: 2009-05-02 00:25 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
the compapp test project (needs the associated bpel project) (28.93 KB, application/x-compressed)
2009-01-08 16:18 UTC, Tientien Li
Details
the associated bpel project (13.40 KB, text/plain)
2009-01-08 16:18 UTC, Tientien Li
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tientien Li 2009-01-08 16:06:11 UTC
Reported by Guido Annaert

Product Version: NetBeans IDE 6.1 (Build 200810140114) - Java CAPS Enabled

Please have a look at attached projects.

CASA_ERR can be perfectly build and deployed.

After renaming CASA_ERR to CASA_ERROR (see screenshot), the build still works but the deployment to AS fails !!! 
Renaming to something else, like CASA_ERR everything works fine again. 

----

Notes add by Tientien

Actually, the SA deployed OK, but could not start, as seen from the sever log:

JBIMA0402: Service Assembly file:/C:/openesb/glassfish-v2-ur2-b04-patch-
081024/domains/domain1/jbi/tmp/upload/3ad9f1a411eb6e3caf37fbf/CASA_ERROR.zip has been deployed.

CompApp and CASA works fine and generated correct SA. It looks like the problem is somewhere between JBI management API 
and JBI run-time... some code is trapping the word "error" and not allowing the deployed SA to start.  I filed a bug at 
JBI manager for now... and we will start debugging from there.
Comment 1 Tientien Li 2009-01-08 16:18:03 UTC
Created attachment 75592 [details]
the compapp test project (needs the associated bpel project)
Comment 2 Tientien Li 2009-01-08 16:18:46 UTC
Created attachment 75593 [details]
the associated bpel project
Comment 3 Jun Qian 2009-01-08 23:21:59 UTC
Fixed in soa-dev branch: http://hg.netbeans.org/soa-dev/rev/10c0de4279fd
Comment 4 Karthikeyan Rajeswaran 2009-01-21 22:16:33 UTC
Fix ported to release61_fixes branch:

changeset 1ee8384d1eb8 in release61_fixes
details: http://hg.netbeans.org/release61_fixes?cmd=changeset;node=1ee8384d1eb8
description: Fix for 6794111
Comment 5 pgebauer 2009-02-05 11:02:19 UTC
The SW has been changed to 61fixes5-verified based on customer verification.
Comment 6 fmartinez1 2009-05-02 00:25:17 UTC
Tested and no longer seeing this problem. Tested with 20090430-0722 build


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo