Bug 156418 - java.lang.AssertionError: Unable to get repository, context contains only unmanaged files!
java.lang.AssertionError: Unable to get repository, context contains only unm...
Status: RESOLVED DUPLICATE of bug 122411
Product: versioncontrol
Classification: Unclassified
Component: Subversion
6.x
All All
: P3 (vote)
: TBD
Assigned To: issues@versioncontrol
issues@versioncontrol
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-07 13:25 UTC by Peter Pis
Modified: 2009-02-19 23:06 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Pis 2009-01-07 13:25:38 UTC
Build: NetBeans IDE Dev (Build 200708080000)
VM: Java HotSpot(TM) Client VM, 1.6.0-b105
OS: Linux, 2.6.20-16-generic, i386
User comments: I have marked in "Projects navigator" all 4 roots that belong to same Enterprise project.
I went to :
     Menu -> Versioning -> Subversion -> Show diff for all 4 projects

And problem occurred.
STACKTRACE: (first 10 lines)
java.lang.AssertionError: Unable to get repository, context contains only unmanaged files!
        at org.netbeans.modules.subversion.Subversion.getClient(Subversion.java:264)
        at org.netbeans.modules.subversion.ui.status.StatusAction.executeStatus(StatusAction.java:82)
        at org.netbeans.modules.subversion.ui.status.VersioningPanel$6.perform(VersioningPanel.java:368)
        at org.netbeans.modules.subversion.client.SvnProgressSupport.performIntern(SvnProgressSupport.java:80)
        at org.netbeans.modules.subversion.client.SvnProgressSupport.run(SvnProgressSupport.java:73)
        at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:539)
        at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:964)
Comment 1 Ondrej Vrabec 2009-02-03 12:40:06 UTC
NPE issue - but execution stops on a prior assertion

*** This issue has been marked as a duplicate of 122411 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo