Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 156369 - NullPointerException at org.netbeans.spi.java.project.classpath.ProjectClassPathModifierImplementation.convertURLsToURIs
NullPointerException at org.netbeans.spi.java.project.classpath.ProjectClassP...
Status: VERIFIED FIXED
Product: projects
Classification: Unclassified
Component: Eclipse project importer
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Jesse Glick
issues@platform
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT 67patch1-verified
:
: 168713 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-06 17:49 UTC by ivanqueiroz
Modified: 2009-07-21 09:42 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.84 KB, text/plain)
2009-01-06 17:49 UTC, ivanqueiroz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ivanqueiroz 2009-01-06 17:49:34 UTC
Build: NetBeans IDE 6.5 (Build 200811100001)
VM: Java HotSpot(TM) Client VM, 1.5.0_16-b02, Java(TM) 2 Runtime Environment, Standard Edition, 1.5.0_16-b02
OS: Windows XP, 5.1, x86

User Comments:
ivanqueiroz: Importing Eclipse project.



Stacktrace: 
java.lang.NullPointerException
        at org.netbeans.spi.java.project.classpath.ProjectClassPathModifierImplementation.convertURLsToURIs(ProjectClassPathModifierImplementation.java:194)
        at org.netbeans.modules.j2ee.common.project.classpath.ClassPathModifier.addRoots(ClassPathModifier.java:134)
        at org.netbeans.spi.java.project.classpath.ProjectClassPathModifierImplementation$Accessor.addRoots(ProjectClassPathModifierImplementation.java:407)
        at org.netbeans.api.java.project.classpath.ProjectClassPathModifier.addRoots(ProjectClassPathModifier.java:142)
        at org.netbeans.modules.projectimport.eclipse.core.spi.ProjectFactorySupport.addItemToClassPath(ProjectFactorySupport.java:339)
        at org.netbeans.modules.projectimport.eclipse.core.spi.ProjectFactorySupport.updateProjectClassPath(ProjectFactorySupport.java:107)
Comment 1 ivanqueiroz 2009-01-06 17:49:39 UTC
Created attachment 75505 [details]
stacktrace
Comment 2 David Konecny 2009-04-07 01:02:17 UTC
Perhaps ProjectFactorySupport is passing null to addRoots?
Comment 3 Jesse Glick 2009-06-09 20:28:06 UTC
core-main #cdcd3a28e032
Comment 4 Quality Engineering 2009-06-11 08:46:10 UTC
Integrated into 'main-golden', will be available in build *200906110201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/cdcd3a28e032
User: Jesse Glick <jglick@netbeans.org>
Log: #156369: NPE.
Comment 5 Jesse Glick 2009-07-02 16:19:41 UTC
No idea how to reproduce or verify but might be reasonable to backport.
Comment 6 Petr Blaha 2009-07-03 07:47:12 UTC
v.
Comment 7 pgebauer 2009-07-07 16:05:48 UTC
The fix has been ported into the release67_fixes repository.
http://hg.netbeans.org/release67_fixes/rev/9abf379873cd
Comment 8 Jesse Glick 2009-07-16 21:55:34 UTC
*** Issue 168713 has been marked as a duplicate of this issue. ***
Comment 9 Jindrich Sedek 2009-07-21 09:42:31 UTC
reviewed in 67_fixes


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo