Bug 156340 - deadlock while opening groovy file (from test roots)
deadlock while opening groovy file (from test roots)
Status: RESOLVED DUPLICATE of bug 156443
Product: editor
Classification: Unclassified
Component: Parsing & Indexing
6.x
All Windows Vista
: P2 (vote)
: 6.x
Assigned To: issues@editor
issues@editor
: RANDOM, THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-06 11:03 UTC by Lukas Jungmann
Modified: 2009-02-19 20:45 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
threaddump (19.25 KB, text/plain)
2009-01-06 11:04 UTC, Lukas Jungmann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lukas Jungmann 2009-01-06 11:03:58 UTC
full ide, hudson #4734, vista, jdk1.6.0_10

-start ide with fresh userdir
-open java and web projects from favorites window
-register GF-v2 in the IDE (using resolve missing server dialog)
-activated groovy modules (using tools->plugins)
-open groovy test file from java app's test root in the editor

=>
Found one Java-level deadlock:
=============================
"Document Processing":
  waiting to lock monitor 0x33ea364c (object 0x0aed97f0, a org.netbeans.modules.parsing.api.Source),
  which is held by "OpenIDE-request-processor-6"
"OpenIDE-request-processor-6":
  waiting to lock monitor 0x341f6664 (object 0x0aee0570, a org.openide.windows.CloneableOpenSupport$Listener),
  which is held by "Document Processing"
Comment 1 Lukas Jungmann 2009-01-06 11:04:25 UTC
Created attachment 75482 [details]
threaddump
Comment 2 Vitezslav Stejskal 2009-01-07 12:04:43 UTC
Synchronization troubles in boggy SourceCache...
Comment 3 Vitezslav Stejskal 2009-01-08 09:41:09 UTC

*** This issue has been marked as a duplicate of 156443 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo